summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-12-11 16:43:22 +0000
committerDaniel Bermond2020-12-11 16:43:22 +0000
commitcd007b847912f8a2c4cf2998e35cb7f6aa4929cb (patch)
treee0126d4c13655cb59df769a84bb2adc3e69f2bc8
parent33e47ba9554fd6d52b10db47ccd475fdd40f8471 (diff)
downloadaur-xine-lib-hg.tar.gz
Remove gcc10 patch (fixed upstream). Update dependencies.
-rw-r--r--.SRCINFO85
-rw-r--r--010-xine-lib-hg-gcc10-fix.patch15
-rw-r--r--PKGBUILD71
3 files changed, 79 insertions, 92 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a4c926c2c31..fa6686491b4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,61 +1,68 @@
pkgbase = xine-lib-hg
- pkgdesc = A multimedia playback engine (mercurial version)
- pkgver = 1.2.10.r211.79af5718c10d
+ pkgdesc = Multimedia playback engine (mercurial version)
+ pkgver = 1.2.11.r6.09aa41e45228
pkgrel = 1
- url = http://xine.sourceforge.net/
+ url = https://www.xine-project.org
arch = x86_64
license = GPL
license = LGPL
makedepends = mercurial
- makedepends = wavpack
- makedepends = faad2
- makedepends = libmng
- makedepends = imagemagick
makedepends = mesa
- makedepends = libmodplug
+ makedepends = libdvdnav
+ makedepends = libdvdread
makedepends = vcdimager
- makedepends = jack
+ makedepends = glu
+ makedepends = sdl
+ makedepends = wayland
makedepends = aalib
- makedepends = libdca
makedepends = a52dec
+ makedepends = faad2
+ makedepends = flac
+ makedepends = libdca
makedepends = libmad
- makedepends = libdvdnav
makedepends = libmpcdec
- makedepends = libcaca
- makedepends = libbluray
- makedepends = libvdpau
- makedepends = glu
+ makedepends = wavpack
makedepends = gdk-pixbuf2
- depends = libxvmc
+ makedepends = imagemagick
+ makedepends = libcaca
+ makedepends = libmng
+ makedepends = libnfs
+ makedepends = smbclient
depends = ffmpeg
- depends = libxinerama
+ depends = libjpeg-turbo
depends = libnsl
- depends = libssh2
- optdepends = imagemagick: for using the imagemagick plugin
- optdepends = jack: for using the jack plugin
- optdepends = vcdimager: for using the vcd plugin
- optdepends = glu: for using the opengl plugin
- optdepends = wavpack: for using the wavpack plugin
- optdepends = faad2: for using the faad plugin
- optdepends = libmng: for using the mng plugin
- optdepends = aalib: for using the aalib plugin
- optdepends = libmodplug: for using the modplug plugin
- optdepends = libdca: for using the dca plugin
- optdepends = a52dec: for using the a52 plugin
- optdepends = libmad: for using the mp3 plugin
- optdepends = libdvdnav: for using the dvd plugin
- optdepends = libmpcdec: for using the musepack plugin
- optdepends = libcaca: for using the caca plugin
- optdepends = libbluray: for using the bluray plugin
- optdepends = libvdpau: for using the VDPAU plugin
- optdepends = smbclient: for using the samba plugin
- optdepends = gdk-pixbuf2: for using the gdk-pixbuf plugin
+ depends = libpng
+ depends = libx11
+ depends = libxcb
+ depends = libxext
+ depends = libxinerama
+ depends = libxv
+ depends = libxvmc
+ depends = zlib
+ optdepends = libdvdnav: for dvd plugin
+ optdepends = libdvdread: for spu and dxr3 plugins
+ optdepends = vcdimager: for vcd plugin
+ optdepends = glu: for opengl and vaapi plugins
+ optdepends = sdl: for sdl plugin
+ optdepends = wayland: for egl_wl plugin
+ optdepends = aalib: for aalib plugin
+ optdepends = a52dec: for a52 plugin
+ optdepends = faad2: for faad plugin
+ optdepends = flac: for flac plugin
+ optdepends = libdca: for dts (dca) plugin
+ optdepends = libmad: for mad (mp3) plugin
+ optdepends = libmpcdec: for mpc (musepack) plugin
+ optdepends = wavpack: for wavpack plugin
+ optdepends = gdk-pixbuf2: for gdk_pixbuf plugin
+ optdepends = imagemagick: for imagemagick plugin
+ optdepends = libcaca: for caca plugin
+ optdepends = libmng: for mng plugin
+ optdepends = libnfs: for nfs plugin
+ optdepends = smbclient: for samba plugin
provides = xine-lib
conflicts = xine-lib
source = hg+http://hg.code.sf.net/p/xine/xine-lib-1.2
- source = 010-xine-lib-hg-gcc10-fix.patch
sha256sums = SKIP
- sha256sums = 357daf6042d592556b4b23d400d622be4e165dc7d3bce8ce2ab638abf357f2e6
pkgname = xine-lib-hg
diff --git a/010-xine-lib-hg-gcc10-fix.patch b/010-xine-lib-hg-gcc10-fix.patch
deleted file mode 100644
index e6d45f4b1f47..000000000000
--- a/010-xine-lib-hg-gcc10-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/src/libreal/real_common.h
-+++ b/src/libreal/real_common.h
-@@ -75,10 +75,10 @@
- const char *const codec_name,
- const char *const codec_alternate);
-
--const decoder_info_t dec_info_realvideo;
-+extern const decoder_info_t dec_info_realvideo;
- void *init_realvdec (xine_t *xine, const void *data);
-
--const decoder_info_t dec_info_realaudio;
-+extern const decoder_info_t dec_info_realaudio;
- void *init_realadec (xine_t *xine, const void *data);
-
- #endif
diff --git a/PKGBUILD b/PKGBUILD
index 61f4106a6335..221f6b1f8f16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,42 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=xine-lib-hg
-pkgver=1.2.10.r211.79af5718c10d
+pkgver=1.2.11.r6.09aa41e45228
pkgrel=1
-pkgdesc='A multimedia playback engine (mercurial version)'
+pkgdesc='Multimedia playback engine (mercurial version)'
arch=('x86_64')
-url='http://xine.sourceforge.net/'
+url='https://www.xine-project.org'
license=('GPL' 'LGPL')
-depends=('libxvmc' 'ffmpeg' 'libxinerama' 'libnsl' 'libssh2')
-makedepends=('mercurial'
- 'wavpack' 'faad2' 'libmng' 'imagemagick' 'mesa' 'libmodplug'
- 'vcdimager' 'jack' 'aalib' 'libdca' 'a52dec' 'libmad' 'libdvdnav'
- 'libmpcdec' 'libcaca' 'libbluray' 'libvdpau' 'glu' 'gdk-pixbuf2')
-optdepends=('imagemagick: for using the imagemagick plugin'
- 'jack: for using the jack plugin'
- 'vcdimager: for using the vcd plugin'
- 'glu: for using the opengl plugin'
- 'wavpack: for using the wavpack plugin'
- 'faad2: for using the faad plugin'
- 'libmng: for using the mng plugin'
- 'aalib: for using the aalib plugin'
- 'libmodplug: for using the modplug plugin'
- 'libdca: for using the dca plugin'
- 'a52dec: for using the a52 plugin'
- 'libmad: for using the mp3 plugin'
- 'libdvdnav: for using the dvd plugin'
- 'libmpcdec: for using the musepack plugin'
- 'libcaca: for using the caca plugin'
- 'libbluray: for using the bluray plugin'
- 'libvdpau: for using the VDPAU plugin'
- 'smbclient: for using the samba plugin'
- 'gdk-pixbuf2: for using the gdk-pixbuf plugin')
+depends=('ffmpeg' 'libjpeg-turbo' 'libnsl' 'libpng' 'libx11' 'libxcb'
+ 'libxext' 'libxinerama' 'libxv' 'libxvmc' 'zlib')
+optdepends=('libdvdnav: for dvd plugin'
+ 'libdvdread: for spu and dxr3 plugins'
+ 'vcdimager: for vcd plugin'
+ 'glu: for opengl and vaapi plugins'
+ 'sdl: for sdl plugin'
+ 'wayland: for egl_wl plugin'
+ 'aalib: for aalib plugin'
+ 'a52dec: for a52 plugin'
+ 'faad2: for faad plugin'
+ 'flac: for flac plugin'
+ 'libdca: for dts (dca) plugin'
+ 'libmad: for mad (mp3) plugin'
+ 'libmpcdec: for mpc (musepack) plugin'
+ 'wavpack: for wavpack plugin'
+ 'gdk-pixbuf2: for gdk_pixbuf plugin'
+ 'imagemagick: for imagemagick plugin'
+ 'libcaca: for caca plugin'
+ 'libmng: for mng plugin'
+ 'libnfs: for nfs plugin'
+ 'smbclient: for samba plugin')
+makedepends=('mercurial' 'mesa' 'libdvdnav' 'libdvdread' 'vcdimager' 'glu' 'sdl'
+ 'wayland' 'aalib' 'a52dec' 'faad2' 'flac' 'libdca' 'libmad'
+ 'libmpcdec' 'wavpack' 'gdk-pixbuf2' 'imagemagick' 'libcaca'
+ 'libmng' 'libnfs' 'smbclient')
provides=('xine-lib')
conflicts=('xine-lib')
-source=('hg+http://hg.code.sf.net/p/xine/xine-lib-1.2'
- '010-xine-lib-hg-gcc10-fix.patch')
-sha256sums=('SKIP'
- '357daf6042d592556b4b23d400d622be4e165dc7d3bce8ce2ab638abf357f2e6')
-
-prepare() {
- patch -d xine-lib-1.2 -Np1 -i"${srcdir}/010-xine-lib-hg-gcc10-fix.patch"
-}
+source=('hg+http://hg.code.sf.net/p/xine/xine-lib-1.2')
+sha256sums=('SKIP')
pkgver() {
printf '%s.r%s.%s' "$(hg -R xine-lib-1.2 log -r. --template '{latesttag}')" \
@@ -52,10 +48,9 @@ build() {
cd xine-lib-1.2
./autogen.sh \
--prefix='/usr' \
- --with-wavpack \
- --enable-vdpau \
+ --enable-antialiasing \
--with-external-dvdnav \
- --disable-optimizations
+ --with-wavpack
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}