diff options
author | Aidan Coward | 2020-01-03 22:13:53 -0500 |
---|---|---|
committer | Aidan Coward | 2020-01-03 22:13:53 -0500 |
commit | aee6c8b87cf88c77165905adc93128a4d2a2e440 (patch) | |
tree | ac9dc01d8edc2fda821dede32b30dce850dd81a3 | |
parent | 7cc44e16dd1ac35cf84d8c39d85b276afe4c5c3f (diff) | |
download | aur-aee6c8b87cf88c77165905adc93128a4d2a2e440.tar.gz |
previous version didn't correctly modify scripts to start mage-client or
mage-server.
QoL updates:
- New README.txt file
- New systemd unit file to start mage-server on boot
- Modified xmage.install file to reflect addition of README.txt
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | .gitignore | 3 | ||||
-rw-r--r-- | PKGBUILD | 10 | ||||
-rw-r--r-- | README.txt | 15 | ||||
-rw-r--r-- | mage-server.service | 9 | ||||
-rw-r--r-- | xmage.install | 10 |
6 files changed, 35 insertions, 14 deletions
@@ -1,7 +1,7 @@ pkgbase = xmage pkgdesc = Java-based program for playing Magic:The Gathering, including client and server pkgver = 1.4.41V1a - pkgrel = 2 + pkgrel = 3 url = http://xmage.de install = xmage.install arch = any diff --git a/.gitignore b/.gitignore index 5a6fc6d9e98e..55ae4d5a119d 100644 --- a/.gitignore +++ b/.gitignore @@ -1,2 +1,3 @@ -git-notes.txt +git-notes.txt* *.zip +up.sh @@ -2,7 +2,7 @@ pkgname=xmage pkgver=1.4.41V1a -pkgrel=2 +pkgrel=3 pkgdesc="Java-based program for playing Magic:The Gathering, including client and server" @@ -51,8 +51,8 @@ package() { awk '{ sub("\r$", ""); print }' mage-server/startServer.sh > mage-server/startServer-unix.sh msg2 "changing default locations of scripts..." - awk '{ sub("\.\/lib", "/usr/share/xmage/mage-client/lib"); print }' mage-client/startClient-unix.sh > mage-client/startClient-unix.sh - awk '{ sub("\.\/lib", "/usr/share/xmage/mage-server/lib"); print }' mage-server/startServer-unix.sh > mage-server/startServer-unix.sh + sed -i 's|\.\/lib|\/usr\/share\/xmage\/mage-client\/lib|' mage-client/startClient-unix.sh + sed -i 's|\.\/lib|\/usr\/share\/xmage\/mage-server\/lib|' mage-server/startServer-unix.sh msg2 "adding cd to relevant /usr/share/xmage/ directory..." sed -i '2i cd /usr/share/xmage/mage-client' mage-client/startClient-unix.sh @@ -83,5 +83,9 @@ fi msg2 "installing license: ${license}..." install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licences/"${pkgname}"/LICENSE.txt + + msg2 "installing mage-server systemd unit file to /usr/lib/systemd/system..." + mkdir -p "${pkgdir}"/usr/lib/systemd/system + install -m755 ../mage-server.service "${pkgdir}"/usr/lib/systemd/system } diff --git a/README.txt b/README.txt new file mode 100644 index 000000000000..fd606ae3dcbc --- /dev/null +++ b/README.txt @@ -0,0 +1,15 @@ +The developers assign 512MB of memory to each of mage-client and mage-server. +This is changed to 2048MB in the PKGBUILD. If you wish to modify this, change the -Xmx2048m in +/bin/mage-client or /bin/mage-server. + +Due to compatibility issues with the current version of java in the repositories, +xmage now installs a dedicated version of java to /usr/share/xmage/java. +This is only applicable for x86_64 machines. For all other architectures, the package requires +the jre8-openjdk package. The developers only guarantee compatibility with a single version of +java. + +If you encounter a gray/blank screen when you start the client, see here for a possible solution +https://www.reddit.com/r/XMage/comments/9k2t9o/new_install_blank_screen_when_launching_client/ + +The package comes with a systemd unit file to load mage-server on boot. +It is automatically installed to /usr/lib/systemd/system/mage-server.service diff --git a/mage-server.service b/mage-server.service new file mode 100644 index 000000000000..59578a848b0d --- /dev/null +++ b/mage-server.service @@ -0,0 +1,9 @@ +[Unit] +Description=Starts mage-server on boot + +[Service] +Type=simple +ExecStart=/usr/bin/mage-server + +[Install] +WantedBy=multi-user.target diff --git a/xmage.install b/xmage.install index 6ec7fba9b915..84de0bba7ab6 100644 --- a/xmage.install +++ b/xmage.install @@ -1,15 +1,7 @@ post_install() { echo echo "==> xmage's files are located in /usr/share/xmage" - echo "==>" - echo "==> xmage will automatically increase the (default)" - echo "==> amount of RAM available to both the client" - echo "==> and the server from 512MB to 1024MB" - echo "==> If you wish to change the amount of RAM available" - echo "==> to xmage, edit /bin/mage-client or /bin/mage-server" - echo "==> and change the 1024 in '-Xmx1024m' to the amount" - echo "==> of RAM(in MB) you wish to make available" - echo + echo "==> For details, check /usr/share/xmage/README.txt" } post_upgrade() { |