summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2016-06-08 12:26:38 +1000
committerRod Kay2016-06-08 12:26:38 +1000
commit9b36c8cb23b128ff4e02a25bbaa41ce850f021ff (patch)
tree08bbe8e8b971016a76c6acf770591436ccad067a
parent7cffdecedf8d8311f8ab5624ac122206bb904528 (diff)
downloadaur-9b36c8cb23b128ff4e02a25bbaa41ce850f021ff.tar.gz
Use gprbuild binary to break the xmlada/grpbuild circular dependency.
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.archy150
-rw-r--r--PKGBUILD9
-rw-r--r--generic_gpr.in19
-rw-r--r--patch-xmlada-config.in35
5 files changed, 11 insertions, 208 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 858e3728532e..e867a82044dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jun 5 05:02:04 UTC 2016
+# Wed Jun 8 02:26:23 UTC 2016
pkgbase = xmlada
pkgdesc = A full XML suite for Ada
pkgver = 2016
@@ -10,7 +10,9 @@ pkgbase = xmlada
license = GPL
depends = gcc-ada
source = http://mirrors.cdn.adacore.com/art/57399978c7a447658e0affc0
- md5sums = 631957d2f55277f1d58a68186fbf5022
+ source = http://mirrors.cdn.adacore.com/art/5739cbf1c7a447658d00e326
+ sha1sums = a9c840d9d05ed865aa7c960d9f27cf7cd93e12b9
+ sha1sums = 270aa41c2ed6381460502ac00ecef7dfefd07000
pkgname = xmlada
diff --git a/Makefile.archy b/Makefile.archy
deleted file mode 100644
index 72ba10f5eb68..000000000000
--- a/Makefile.archy
+++ /dev/null
@@ -1,150 +0,0 @@
-ADALIB!= gnatls -v | grep adalib | awk '{print $$1}'
-
-PROCESSORS=7
-
-STATIC_FLAGS= -gnatQ -O2 -gnatn -gnatp -gnatA -j${PROCESSORS}
-DYNAMIC_FLAGS= -fPIC ${STATIC_FLAGS}
-
-ECHO=echo
-
-LIBVER=4.6.0.0
-
-CURRENT_FOLDER=$(shell pwd)
-
-#
-# unicode depends on nothing
-#
-
-unicode/lib/static/libxmlada_unicode.a: unicode/dummy_unicode.adb
- @echo building static unicode/lib/static/libxmlada_unicode.a library
- @rm -f unicode/lib/static/libxmlada_unicode.a
- gnatmake -c unicode/dummy_unicode.adb -D unicode/obj/static ${STATIC_FLAGS}
- rm unicode/obj/static/dummy*
- ar cq unicode/lib/static/libxmlada_unicode.a unicode/obj/static/*.o
- ranlib unicode/lib/static/libxmlada_unicode.a
-
-unicode/lib/relocatable/libxmlada_unicode.so: unicode/dummy_unicode.adb
- @${ECHO} building shared library unicode/lib/relocatable/libxmlada_unicode.so
- @rm -f unicode/lib/relocatable/libxmlada_unicode.so unicode/lib/relocatable/libxmlada_unicode.so.${LIBVER}
- gnatmake -c unicode/dummy_unicode.adb -D unicode/obj/relocatable ${DYNAMIC_FLAGS}
- rm unicode/obj/relocatable/dummy*
- gcc -shared -Wl,-rpath,${PREFIX}/lib/xmlada/relocatable \
- -L${ADALIB} -lgnat -Wl,-rpath,${ADALIB} \
- -o unicode/lib/relocatable/libxmlada_unicode.so.${LIBVER} -Wl,-soname,unicode/lib/relocatable/libxmlada_unicode.so.${LIBVER} \
- unicode/obj/relocatable/*.o
- ln -s $(CURRENT_FOLDER)/unicode/lib/relocatable/libxmlada_unicode.so.${LIBVER} unicode/lib/relocatable/libxmlada_unicode.so
-
-#
-# input sources depends on unicode
-#
-
-input_sources/lib/static/libxmlada_input_sources.a: input_sources/dummy_input_sources.adb unicode/lib/static/libxmlada_unicode.a
- @echo building static input_sources/lib/static/libxmlada_input_sources.a library
- @rm -f input_sources/lib/static/libxmlada_input_sources.a
- gnatmake -c input_sources/dummy_input_sources.adb -D input_sources/obj/static -aOunicode/obj/static -aIunicode ${STATIC_FLAGS}
- rm input_sources/obj/static/dummy*
- ar cq input_sources/lib/static/libxmlada_input_sources.a input_sources/obj/static/*.o
- ranlib input_sources/lib/static/libxmlada_input_sources.a
-
-input_sources/lib/relocatable/libxmlada_input_sources.so: input_sources/dummy_input_sources.adb unicode/lib/relocatable/libxmlada_unicode.so
- @${ECHO} building shared library input_sources/lib/relocatable/libxmlada_input_sources.so
- @rm -f input_sources/lib/relocatable/libxmlada_input_sources.so input_sources/lib/relocatable/libxmlada_input_sources.so.${LIBVER}
- gnatmake -c input_sources/dummy_input_sources.adb -D input_sources/obj/relocatable -aOunicode/obj/relocatable -aIunicode ${DYNAMIC_FLAGS}
- rm input_sources/obj/relocatable/dummy*
- gcc -shared -Wl,-rpath,${PREFIX}/lib/xmlada/relocatable \
- -L${ADALIB} -lgnat -Wl,-rpath,${ADALIB} \
- -Lunicode/lib/relocatable -lxmlada_unicode \
- -o input_sources/lib/relocatable/libxmlada_input_sources.so.${LIBVER} -Wl,-soname,input_sources/lib/relocatable/libxmlada_input_sources.so.${LIBVER} \
- input_sources/obj/relocatable/*.o
- ln -s $(CURRENT_FOLDER)/input_sources/lib/relocatable/libxmlada_input_sources.so.${LIBVER} input_sources/lib/relocatable/libxmlada_input_sources.so
-
-#
-# sax depends on input sources and unicode (sufficent to limit to I.S)
-#
-
-sax/lib/static/libxmlada_sax.a: sax/dummy_sax.adb input_sources/lib/static/libxmlada_input_sources.a
- @echo building static sax/lib/static/libxmlada_sax.a library
- @rm -f sax/lib/static/libxmlada_sax.a
- gnatmake -c sax/dummy_sax.adb -D sax/obj/static -aOunicode/obj/static -aOinput_sources/obj/static -aIunicode -aIinput_sources ${STATIC_FLAGS}
- rm sax/obj/static/dummy*
- ar cq sax/lib/static/libxmlada_sax.a sax/obj/static/*.o
- ranlib sax/lib/static/libxmlada_sax.a
-
-sax/lib/relocatable/libxmlada_sax.so: sax/dummy_sax.adb input_sources/lib/relocatable/libxmlada_input_sources.so
- @${ECHO} building shared library sax/lib/relocatable/libxmlada_sax.so
- @rm -f sax/lib/relocatable/libxmlada_sax.so sax/lib/relocatable/libxmlada_sax.so.${LIBVER}
- gnatmake -c sax/dummy_sax.adb -D sax/obj/relocatable -aOunicode/obj/relocatable -aOinput_sources/obj/relocatable -aIunicode -aIinput_sources ${DYNAMIC_FLAGS}
- rm sax/obj/relocatable/dummy*
- gcc -shared -Wl,-rpath,${PREFIX}/lib/xmlada/relocatable \
- -L${ADALIB} -lgnat -Wl,-rpath,${ADALIB} \
- -Lunicode/lib/relocatable -lxmlada_unicode \
- -Linput_sources/lib/relocatable -lxmlada_input_sources \
- -o sax/lib/relocatable/libxmlada_sax.so.${LIBVER} -Wl,-soname,sax/lib/relocatable/libxmlada_sax.so.${LIBVER} \
- sax/obj/relocatable/*.o
- ln -s $(CURRENT_FOLDER)/sax/lib/relocatable/libxmlada_sax.so.${LIBVER} sax/lib/relocatable/libxmlada_sax.so
-
-#
-# dom depends on three other libraries (sufficent to limit to sax)
-#
-
-dom/lib/static/libxmlada_dom.a: dom/dummy_dom.adb sax/lib/static/libxmlada_sax.a
- @echo building static dom/lib/static/libxmlada_dom.a library
- @rm -f dom/lib/static/libxmlada_dom.a
- gnatmake -c dom/dummy_dom.adb -D dom/obj/static -aOunicode/obj/static -aOinput_sources/obj/static -aOsax/obj/static -aIunicode -aIinput_sources -aIsax ${STATIC_FLAGS}
- rm dom/obj/static/dummy*
- ar cq dom/lib/static/libxmlada_dom.a dom/obj/static/*.o
- ranlib dom/lib/static/libxmlada_dom.a
-
-dom/lib/relocatable/libxmlada_dom.so: dom/dummy_dom.adb sax/lib/relocatable/libxmlada_sax.so
- @${ECHO} building shared library dom/lib/relocatable/libxmlada_dom.so
- @rm -f dom/lib/relocatable/libxmlada_dom.so dom/lib/relocatable/libxmlada_dom.so.${LIBVER}
- gnatmake -c dom/dummy_dom.adb -D dom/obj/relocatable -aOunicode/obj/relocatable -aOinput_sources/obj/relocatable -aOsax/obj/relocatable -aIunicode -aIinput_sources -aIsax ${DYNAMIC_FLAGS}
- rm dom/obj/relocatable/dummy*
- gcc -shared -Wl,-rpath,${PREFIX}/lib/xmlada/relocatable \
- -L${ADALIB} -lgnat -Wl,-rpath,${ADALIB} \
- -Lunicode/lib/relocatable -lxmlada_unicode \
- -Linput_sources/lib/relocatable -lxmlada_input_sources \
- -Lsax/lib/relocatable -lxmlada_sax \
- -o dom/lib/relocatable/libxmlada_dom.so.${LIBVER} -Wl,-soname,dom/lib/relocatable/libxmlada_dom.so.${LIBVER} \
- dom/obj/relocatable/*.o
- ln -s $(CURRENT_FOLDER)/dom/lib/relocatable/libxmlada_dom.so.${LIBVER} dom/lib/relocatable/libxmlada_dom.so
-
-#
-# schema depends on four other libraries (sufficent to limit to dom)
-#
-
-schema/lib/static/libxmlada_schema.a: schema/dummy_schema.adb dom/lib/static/libxmlada_dom.a
- @echo building static schema/lib/static/libxmlada_schema.a library
- @rm -f schema/lib/static/libxmlada_schema.a
- gnatmake -c schema/dummy_schema.adb -D schema/obj/static -aOunicode/obj/static -aOinput_sources/obj/static -aOsax/obj/static -aOdom/obj/static -aIunicode -aIinput_sources -aIsax -aIdom ${STATIC_FLAGS}
- rm schema/obj/static/dummy*
- ar cq schema/lib/static/libxmlada_schema.a schema/obj/static/*.o
- ranlib schema/lib/static/libxmlada_schema.a
-
-schema/lib/relocatable/libxmlada_schema.so: schema/dummy_schema.adb dom/lib/relocatable/libxmlada_dom.so
- @${ECHO} ${CURRENT_FOLDER} ************************** building shared library schema/lib/relocatable/libxmlada_schema.so
- @rm -f schema/lib/relocatable/libxmlada_schema.so schema/lib/relocatable/libxmlada_schema.so.${LIBVER}
- gnatmake -c schema/dummy_schema.adb -D schema/obj/relocatable -aOunicode/obj/relocatable -aOinput_sources/obj/relocatable -aOsax/obj/relocatable -aOdom/obj/relocatable -aIunicode -aIinput_sources -aIsax -aIdom ${DYNAMIC_FLAGS}
- rm schema/obj/relocatable/dummy*
- gcc -shared -Wl,-rpath,${PREFIX}/lib/xmlada/relocatable \
- -L${ADALIB} -lgnat -Wl,-rpath,${ADALIB} \
- -Lunicode/lib/relocatable -lxmlada_unicode \
- -Linput_sources/lib/relocatable -lxmlada_input_sources \
- -Lsax/lib/relocatable -lxmlada_sax \
- -Ldom/lib/relocatable -lxmlada_dom \
- -o schema/lib/relocatable/libxmlada_schema.so.${LIBVER} -Wl,-soname,schema/lib/relocatable/libxmlada_schema.so.${LIBVER} \
- schema/obj/relocatable/*.o
- ln -s $(CURRENT_FOLDER)/schema/lib/relocatable/libxmlada_schema.so.${LIBVER} schema/lib/relocatable/libxmlada_schema.so
-
-#
-# Sphinx documentation
-#
-
-docs:
- ${MAKE} -e -C docs
-
-
-all: schema/lib/static/libxmlada_schema.a schema/lib/relocatable/libxmlada_schema.so
-
-
-
diff --git a/PKGBUILD b/PKGBUILD
index 918e3444c32b..4039264ff208 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,14 +13,19 @@ license=('GPL')
depends=("gcc-ada")
-source=(http://mirrors.cdn.adacore.com/art/57399978c7a447658e0affc0)
-md5sums=('631957d2f55277f1d58a68186fbf5022')
+source=(http://mirrors.cdn.adacore.com/art/57399978c7a447658e0affc0
+ http://mirrors.cdn.adacore.com/art/5739cbf1c7a447658d00e326)
+
+sha1sums=('a9c840d9d05ed865aa7c960d9f27cf7cd93e12b9'
+ '270aa41c2ed6381460502ac00ecef7dfefd07000')
build()
{
cd $srcdir/$pkgname-gpl-$pkgver-src
+ export PATH=$srcdir/gprbuild-gpl-2016-x86_64-linux-bin/bin:$PATH
+
./configure --prefix=/usr
make static relocatable
}
diff --git a/generic_gpr.in b/generic_gpr.in
deleted file mode 100644
index f3ed30face72..000000000000
--- a/generic_gpr.in
+++ /dev/null
@@ -1,19 +0,0 @@
-with "xmlada_@DEPENDS@";
-project XmlAda_@ZONE@ is
- for Library_Name use "xmlada_@ZONE@";
- Version := "@VERSION@";
- So_Ext := ".so";
-
- type Xmlada_Kind_Type is ("static", "relocatable");
- Xmlada_Kind : Xmlada_Kind_Type := external ("LIBRARY_TYPE", "static");
- Libdir := "../../lib/xmlada/" & Xmlada_Kind;
-
- for Library_Kind use Xmlada_Kind;
- for Library_Dir use Libdir;
- for Library_Version use
- "lib" & Project'Library_Name & So_Ext & "." & Version;
- for Source_Dirs use ("../../include/xmlada");
- for Source_Files use ("@ZONE@.ads"@FILES@);
- for Externally_Built use "true";
-
-end XmlAda_@ZONE@;
diff --git a/patch-xmlada-config.in b/patch-xmlada-config.in
deleted file mode 100644
index 792561bf85cc..000000000000
--- a/patch-xmlada-config.in
+++ /dev/null
@@ -1,35 +0,0 @@
-*** xmlada-config.in-orig 2014-09-30 03:38:49.000000000 +1000
---- xmlada-config.in 2015-07-26 07:04:02.197674720 +1000
-***************
-*** 8,15 ****
- exec_prefix=@exec_prefix@
- libdir=@libdir@/xmlada
-
-- cflags_static=""
-- cflags_relocatable=""
- mflags_static=""
- mflags_relocatable=""
- libs_relocatable=""
---- 8,13 ----
-***************
-*** 17,26 ****
- full_libs_relocatable=""
- full_libs_static=""
-
-! for module in dom sax schema unicode input; do
-! cflags_static="${cflags_static} -I@includedir@/xmlada_${module}.static"
-! cflags_relocatble="${cflags_relocatable} -I@includedir@/xmlada_${module}.relocatable"
-
- mflags_static="${mflags_static} -aI@includedir@/xmlada_${module}.static -aO@libdir@/xmlada_${module}.static"
- mflags_relocatable="${mflags_relocatable} -aI@includedir@/xmlada_${module}.relocatable -aO@libdir@/xmlada_${module}.relocatable"
- done
---- 15,23 ----
- full_libs_relocatable=""
- full_libs_static=""
-
-! cflags=-I@includedir@/xmlada
-
-+ for module in dom sax schema unicode input; do
- mflags_static="${mflags_static} -aI@includedir@/xmlada_${module}.static -aO@libdir@/xmlada_${module}.static"
- mflags_relocatable="${mflags_relocatable} -aI@includedir@/xmlada_${module}.relocatable -aO@libdir@/xmlada_${module}.relocatable"
- done