summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdel Qalieh2017-07-01 19:56:09 -0400
committerAdel Qalieh2017-07-01 19:56:09 -0400
commit26a70032d8a213782bc096540d2d7e76a215673f (patch)
tree82cdec2e6417f514ada237788bf6d7a4dd2bee97
parentaea3e183113549245516f7e4a4b57bdfd7e55d3f (diff)
downloadaur-xmltooling-c.tar.gz
Release package
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f560c20ca207..ade235aa6c2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
-# Generated by mksrcinfo v8
-# Mon Jan 11 02:33:44 UTC 2016
pkgbase = xmltooling-c
pkgdesc = A lower-level library that provides a higher level interface to XML processing, particularly in light of signing and encryption
- pkgver = 1.5.6
+ pkgver = 1.6.0
pkgrel = 1
url = http://shibboleth.net/
arch = i686
arch = x86_64
- license = LGPL2
+ license = Apache
depends = gcc-libs
- depends = openssl
+ depends = openssl-1.0
depends = curl
depends = log4shib
depends = xerces-c
depends = boost
depends = xml-security-c
- source = http://shibboleth.net/downloads/c++-opensaml/2.5.5/xmltooling-1.5.6.tar.gz
+ source = http://shibboleth.net/downloads/c++-opensaml/2.6.0/xmltooling-1.6.0.tar.gz
sha256sums = c9e5143cb73529bd21cdf550d3e6e706b7ebbfc6e1241e5742a98618645dcef0
pkgname = xmltooling-c
diff --git a/PKGBUILD b/PKGBUILD
index 674d8530478c..7a62b7fef220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer: Adel Qalieh <aqalieh95 at gmail dot come>
+# Maintainer: Adel Qalieh <aqalieh95 at gmail dot com>
pkgname=xmltooling-c
-pkgver=1.5.6
-_opensamlver=2.5.5
+pkgver=1.6.0
+_opensamlver=2.6.0
pkgrel=1
pkgdesc='A lower-level library that provides a higher level interface to XML processing, particularly in light of signing and encryption'
arch=('i686' 'x86_64')
url="http://shibboleth.net/"
-license=('LGPL2')
+license=('Apache')
-depends=('gcc-libs' 'openssl' 'curl' 'log4shib' 'xerces-c' 'boost' 'xml-security-c')
+depends=('gcc-libs' 'openssl-1.0' 'curl' 'log4shib' 'xerces-c' 'boost' 'xml-security-c')
source=("http://shibboleth.net/downloads/c++-opensaml/${_opensamlver}/xmltooling-${pkgver}.tar.gz")
sha256sums=('c9e5143cb73529bd21cdf550d3e6e706b7ebbfc6e1241e5742a98618645dcef0')
prepare() {
cd "${srcdir}/xmltooling-${pkgver}"
+ PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
+ CFLAGS+=" -I/usr/include/openssl-1.0" \
+ LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl" \
+ CXXFLAGS="-std=gnu++98" \
./configure
}