summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrElendig2018-09-22 10:58:21 +0200
committerMrElendig2018-09-22 10:58:21 +0200
commitcf50cc3de1a5d52bf1415a744925fa54adefea83 (patch)
treeca971857728f442837d57f42898e255a8d5e3be5
parent99979dcf15b248d2b945b737740c3b216389e159 (diff)
downloadaur-cf50cc3de1a5d52bf1415a744925fa54adefea83.tar.gz
update and cleanup
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD29
-rw-r--r--xmonad-contrib.install19
3 files changed, 13 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0efa28cc9c89..eabc8292ab71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,8 +3,6 @@ pkgbase = xmonad-contrib-git
pkgver = v0.13.r81.g3044577
pkgrel = 1
url = http://xmonad.org/
- install = xmonad-contrib.install
- arch = i686
arch = x86_64
license = BSD
makedepends = git
@@ -12,14 +10,13 @@ pkgbase = xmonad-contrib-git
depends = xmonad-git
depends = sh
depends = haskell-x11>=1.6.1
- depends = haskell-x11<1.9
+ depends = haskell-x11<1.10
depends = haskell-x11-xft>=0.2
depends = haskell-utf8-string
depends = haskell-random
depends = haskell-old-time
provides = xmonad-contrib
conflicts = xmonad-contrib
- options = staticlibs
source = git://github.com/xmonad/xmonad-contrib
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c87a6d9ad47f..9edbf38d3db4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,16 @@
# Contributor: orbisvicis <gmail.com>
pkgname=xmonad-contrib-git
-pkgver=v0.13.r81.g3044577
+pkgver=v0.14.r9.ge7c92bc
pkgrel=1
pkgdesc="Add-ons for xmonad"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://xmonad.org/"
license=('BSD')
depends=('ghc'
'xmonad-git'
'sh'
- 'haskell-x11>=1.6.1' 'haskell-x11<1.9'
+ 'haskell-x11>=1.6.1' 'haskell-x11<1.10'
'haskell-x11-xft>=0.2'
'haskell-utf8-string'
'haskell-random'
@@ -21,21 +21,20 @@ depends=('ghc'
makedepends=('git')
conflicts=('xmonad-contrib')
provides=('xmonad-contrib')
-install='xmonad-contrib.install'
-options=('staticlibs')
source=('git://github.com/xmonad/xmonad-contrib')
md5sums=('SKIP')
pkgver() {
cd "${pkgname/-git}"
+ sed -i -e '/semigroups/d' -e 's/utf8-string,/utf8-string/' ${pkgname/-git}.cabal
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir"/${pkgname/-git}
+ cd "${pkgname/-git}"
runhaskell Setup.lhs configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
- --prefix=/usr -fuse_xft --libsubdir=\$compiler/site-local/\$pkgid \
- --docdir=/usr/share/doc/${pkgname}
+ --prefix=/usr -fuse_xft --libsubdir=\$compiler/site-local/\$pkgid \
+ --docdir=/usr/share/doc/${pkgname}
runhaskell Setup build
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
@@ -44,13 +43,9 @@ build() {
}
package() {
- cd "$srcdir"/${pkgname/-git}
- install -D -m744 register.sh "$pkgdir"/usr/share/haskell/${pkgname/-git}/register.sh
- install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/${pkgname/-git}/unregister.sh
- runhaskell Setup.lhs copy --destdir="$pkgdir"
- install -D LICENSE "$pkgdir"/usr/share/licenses/xmonad-contrib/LICENSE
- install -d -m755 "$pkgdir"/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/$pkgname/html "$pkgdir/usr/share/doc/ghc/html/libraries/$pkgname"
-
- find "$pkgdir"/usr/lib -name "*.a" -delete
+ cd "${pkgname/-git}"
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname/-git}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname/-git}.sh"
+ runhaskell Setup.lhs copy --destdir="${pkgdir}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
diff --git a/xmonad-contrib.install b/xmonad-contrib.install
deleted file mode 100644
index 57583b0d57be..000000000000
--- a/xmonad-contrib.install
+++ /dev/null
@@ -1,19 +0,0 @@
-HS_DIR=usr/share/haskell/xmonad-contrib
-
-post_install() {
- ${HS_DIR}/register.sh
- echo "You have to rebuild this package after any change to the haskell deps"
-}
-
-pre_upgrade() {
- ${HS_DIR}/unregister.sh
-}
-
-post_upgrade() {
- ${HS_DIR}/register.sh
- echo "You have to rebuild this package after any change to the haskell deps"
-}
-
-pre_remove() {
- ${HS_DIR}/unregister.sh
-}