summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-09-11 14:15:42 +0200
committeranthraxx2015-09-11 14:15:42 +0200
commit711747d03cf46fe80130c284a91e016c7336864c (patch)
tree1e455239a19b18cd12a29627206d802f1eb821b5
parent2f0ecaa78acde699733a319d402bbd80e4c15ea5 (diff)
downloadaur-xmonad-utils.tar.gz
upgpkg: xmonad-utils 0.1.3.3-2
- cleanup
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD40
2 files changed, 29 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bb1a2acde24..3d509af8e165 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xmonad-utils
pkgdesc = A small collection of X utilities
pkgver = 0.1.3.3
- pkgrel = 1
+ pkgrel = 2
url = http://hackage.haskell.org/package/xmonad-utils
arch = i686
arch = x86_64
@@ -10,12 +10,12 @@ pkgbase = xmonad-utils
makedepends = haskell-x11>=1.3
makedepends = haskell-random
makedepends = haskell-unix
- makedepends = glibc
depends = gmp
- depends = glibc
- options = strip
- source = http://hackage.haskell.org/packages/archive/xmonad-utils/0.1.3.3/xmonad-utils-0.1.3.3.tar.gz
- md5sums = d0ef4c556313f87c8311afd56a6e4ff9
+ depends = libffi
+ depends = libxrandr
+ options = !emptydirs
+ source = xmonad-utils-0.1.3.3.tar.gz::https://hackage.haskell.org/packages/archive/xmonad-utils/0.1.3.3/xmonad-utils-0.1.3.3.tar.gz
+ sha512sums = f969a0b75107266ec5f74edc06075a1ede72857311d8e0494bf5b567d18e0a9d6e5b046dbb2a34783c2eafc18be9576b86aa78415306974718031a7dd652418c
pkgname = xmonad-utils
diff --git a/PKGBUILD b/PKGBUILD
index a66eda6045de..ad86c4e2a09c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
-# Maintainer: Leif Warner <abimelech@gmail.com>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Leif Warner <abimelech@gmail.com>
+
pkgname=xmonad-utils
pkgver=0.1.3.3
-pkgrel=1
-pkgdesc="A small collection of X utilities"
-url="http://hackage.haskell.org/package/${pkgname}"
-license=('custom:BSD3')
+pkgrel=2
+pkgdesc='A small collection of X utilities'
+url='http://hackage.haskell.org/package/xmonad-utils'
arch=('i686' 'x86_64')
-makedepends=('ghc' 'haskell-x11>=1.3' 'haskell-random' 'haskell-unix' 'glibc')
-depends=('gmp' 'glibc')
-options=('strip')
-source=(http://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('d0ef4c556313f87c8311afd56a6e4ff9 ')
+license=('custom:BSD3')
+depends=('gmp' 'libffi' 'libxrandr')
+makedepends=('ghc' 'haskell-x11>=1.3' 'haskell-random' 'haskell-unix')
+options=('!emptydirs')
+source=(${pkgname}-${pkgver}.tar.gz::https://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz)
+sha512sums=('f969a0b75107266ec5f74edc06075a1ede72857311d8e0494bf5b567d18e0a9d6e5b046dbb2a34783c2eafc18be9576b86aa78415306974718031a7dd652418c')
+
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
- runhaskell Setup build
+ cd ${pkgname}-${pkgver}
+ runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
+ runhaskell Setup build
}
+
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+ cd ${pkgname}-${pkgver}
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
+
+# vim: ts=2 sw=2 et: