summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2019-02-08 13:03:17 +0100
committersoloturn2019-02-08 13:06:51 +0100
commit0af915dece9c5cd42470c16aca0f1499b6ce16e0 (patch)
tree151d97d2cbfea9b69c1a20bfbe19cbad385e51b0
downloadaur-0af915dece9c5cd42470c16aca0f1499b6ce16e0.tar.gz
initial commit with cmake and ninja build
this does not yet work. there is an error ==> Starting package()... [0/1] Install the project... -- Install configuration: "" ... CMake Error at bin/cmake_install.cmake:41 (file): file INSTALL cannot find "/srv/http/PKGBUILDs/aur/xmoto-git/src/build/bin/xmoto.bin". Call Stack (most recent call first): cmake_install.cmake:43 (include)
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0152b5dce84c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = xmoto-git
+ pkgdesc = A challenging 2D motocross platform game, where physics play an important role.
+ pkgver = 0.5.11
+ pkgrel = 7
+ url = http://xmoto.tuxfamily.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = git
+ depends = libjpeg
+ depends = libpng
+ depends = lua52
+ depends = sdl_mixer
+ depends = ode
+ depends = curl
+ depends = sqlite
+ depends = sdl_ttf
+ depends = sdl_net
+ depends = glu
+ depends = libxdg-basedir
+ depends = libxml2
+ provides = xmoto
+ conflicts = xmoto
+ source = xmoto-git::git://github.com/xmoto/xmoto.git
+ sha1sums = SKIP
+
+pkgname = xmoto-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..235a8eb0a9c9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/xmoto*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c21594e4ae5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id$
+# Maintainer: soloturn@gmail.com
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Travis Willard <travisw@wmpub.ca>
+# Contributor: Denis (dtonator@gmail.com)
+
+_basename=xmoto
+pkgname="$_basename-git"
+pkgver=0.5.11
+pkgrel=7
+pkgdesc="A challenging 2D motocross platform game, where physics play an important role."
+arch=('i686' 'x86_64')
+url="http://xmoto.tuxfamily.org"
+license=('GPL')
+depends=('libjpeg' 'libpng' 'lua52' 'sdl_mixer' 'ode' 'curl' 'sqlite' 'sdl_ttf'
+ 'sdl_net' 'glu' 'libxdg-basedir' 'libxml2')
+makedepends=('cmake' 'ninja' 'git')
+conflicts=("$_basename")
+provides=("$_basename")
+
+source=("$pkgname::git://github.com/xmoto/$_basename.git")
+sha1sums=('SKIP')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ # Build using the old C++ ABI to fix issue with missing text; the issue
+ # should be fixed in the next stable release (if that ever does happen)
+ CPPFLAGS+=' -D_GLIBCXX_USE_CXX11_ABI=0'
+ cmake ../${pkgbase} -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_SYSTEM_NAME=Linux
+ ninja
+}
+
+package() {
+ cd build
+ DESTDIR="${pkgdir}" mandir=/usr/share/man/man6 ninja install
+
+ # install desktop file
+ install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.desktop" \
+ "${pkgdir}/usr/share/applications/xmoto.desktop"
+
+ # install icon for desktop file
+ install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/extra/xmoto.xpm" \
+ "${pkgdir}/usr/share/pixmaps/xmoto.xpm"
+}
+