summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpushsla2019-10-23 09:00:35 +0000
committerpushsla2019-10-23 09:00:35 +0000
commitd53b76aab8a2a9a00a1085734d56dc0d1deef74e (patch)
treedca9b9b476c98f42ccc8e4cb495ea080ae9f67b1
parent9466460ad11bb1936db3c8b57c641312e7b51b61 (diff)
downloadaur-d53b76aab8a2a9a00a1085734d56dc0d1deef74e.tar.gz
rel 8
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD35
2 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2d5ec806641..0bb79587f571 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = xneur-devel-git
pkgdesc = X Neural Switcher detects the input language and corrects keyboard layout. Git version
pkgver = 0.20.0
- pkgrel = 17
+ pkgrel = 18
url = https://github.com/AndrewCrewKuznetsov/xneur-devel
arch = any
license = GPL
makedepends = git
makedepends = intltool
- depends = enchant
+ depends = enchant1.6
depends = gtk2
depends = libnotify
depends = gstreamer>=1.14.4
diff --git a/PKGBUILD b/PKGBUILD
index 726eaaa1034c..0a2eabe594eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,14 @@
pkgname=xneur-devel-git
pkgver=0.20.0
-pkgrel=17
+pkgrel=18
epoch=
pkgdesc="X Neural Switcher detects the input language and corrects keyboard layout. Git version"
arch=('any')
url="https://github.com/AndrewCrewKuznetsov/xneur-devel"
license=('GPL')
groups=()
-depends=('enchant' 'gtk2' 'libnotify' 'gstreamer>=1.14.4')
+depends=('enchant1.6' 'gtk2' 'libnotify' 'gstreamer>=1.14.4')
makedepends=('git' 'intltool')
checkdepends=()
optdepends=('hunspell-YOUR-LANGUAGE' 'xosd--rebuilding_needed')
@@ -32,34 +32,25 @@ md5sums=('SKIP')
validpgpkeys=()
-#prepare() {
-# #rm -rf "$pkgname-$pkgver"
- #git clone https://github.com/AndrewCrewKuznetsov/xneur-devel "$pkgname-$pkgver" || echo
-#}
-
build() {
- if test -d /opt/xneur; then
- echo "/OPT/XNEUR is not installation path anymore. Delete It. New path is /usr"
- sleep 5
- fi
- echo "New versions of enchant stores as /usr/include/enchant-2"
- echo "So I must symlink it to /usr/include/enchant: "
- sudo ln -s /usr/include/enchant-2 /usr/include/enchant &>/dev/null || echo
- cd "$srcdir/xneur-devel/xneur"
- # If you have xosd, why dont use it?
- if test `pacman -Qs xosd`; then
- ./autogen.sh --prefix=/usr --sysconfdir=/etc --with-gtk=gtk2
- else
- ./autogen.sh --prefix=/usr --sysconfdir=/etc --with-gtk=gtk2 --without-xosd
+ if test ! -h /usr/include/enchant; then
+ echo "You have to check if enchant1.6 is installed"
+ echo "And /usr/include/enchant is a symlink to /usr/include/enchant1.6"
+ echo "ln -s /usr/include/enchant1.6 /usr/include/enchant"
+ exit 127
fi
- make
+
+ cd "$srcdir/xneur-devel/xneur"
+ ./configure --without-xosd --with-gtk=gtk2 --sysconfdir=/etc --prefix=/usr
+ cmake -S . -B build -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
}
package() {
mkdir -p "$pkgdir/usr/bin"
- cd "$srcdir/xneur-devel/xneur"
+ cd "$srcdir/xneur-devel/xneur/build"
make DESTDIR="$pkgdir/" install
}