summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Freund2019-02-27 15:36:59 +0100
committerFlorian Freund2019-02-27 15:36:59 +0100
commita02bb6e00be61ac255a163109252b78de4db3c7a (patch)
tree80310f0f7076b1ca97c4e8e5661237811dda8192
parent569902d686d6edb115f6e00c9ef89a34cbedb4f6 (diff)
downloadaur-a02bb6e00be61ac255a163109252b78de4db3c7a.tar.gz
Improve PKGBUILD
remove unneeded commands add plugin feature
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
-rw-r--r--xournalpp.install6
3 files changed, 10 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e2e38fd1c60..a9970f46a0bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = xournalpp-git
pkgdesc = Xournal++ is a handwriting Notetaking software with PDF annotation support. Supports Pen input like Wacom Tablets.
- pkgver = 1.0.7.124.gd5f89600
+ pkgver = 1.0.8.79.g9cbb2e43
pkgrel = 1
url = https://github.com/xournalpp/xournalpp
install = xournalpp.install
arch = i686
arch = x86_64
- license = GPL-2.0
+ license = GPL2
makedepends = git
makedepends = cmake
makedepends = gettext
@@ -18,6 +18,7 @@ pkgbase = xournalpp-git
depends = libxml2
depends = portaudio
depends = libsndfile
+ depends = lua
optdepends = curl: recording support
optdepends = vlc: recording support
optdepends = alsa-utils: recording support
diff --git a/PKGBUILD b/PKGBUILD
index b4eb2e121773..9f36a75b3046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
_pkgname="xournalpp"
pkgname="${_pkgname}-git"
-pkgver=1.0.7.124.gd5f89600
+pkgver=1.0.8.79.g9cbb2e43
pkgrel=1
pkgdesc='Xournal++ is a handwriting Notetaking software with PDF annotation support. Supports Pen input like Wacom Tablets.'
arch=('i686' 'x86_64')
url="https://github.com/xournalpp/xournalpp"
-license=('GPL-2.0')
+license=('GPL2')
makedepends=('git' 'cmake' 'gettext')
-depends=('texlive-bin' 'gtk3' 'glib2' 'desktop-file-utils' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile')
+depends=('texlive-bin' 'gtk3' 'glib2' 'poppler-glib' 'libxml2' 'portaudio' 'libsndfile' 'lua')
optdepends=('curl: recording support'
'vlc: recording support'
'alsa-utils: recording support')
@@ -27,27 +27,22 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/${_pkgname}/"
-
- test -e "${srcdir}/${_pkgname}/build" || mkdir -p "${srcdir}/${_pkgname}/build"
- cd "${srcdir}/${_pkgname}/build"
+ mkdir -p "${srcdir}/${_pkgname}/build"
+}
+build() {
if [ -z "$XDG_CONFIG_HOME" ]; then
configdir=".config"
else
configdir="$XDG_CONFIG_HOME"
fi
- cmake -DENABLE_TEX="ON" -DCMAKE_INSTALL_PREFIX="/usr/" -DDEV_CONFIG_DIR="$configdir/xournalpp" ..
-}
-
-build() {
cd "${srcdir}/${_pkgname}/build"
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DDEV_CONFIG_DIR="$configdir/xournalpp" ..
make
}
package() {
cd "${srcdir}/${_pkgname}/build"
- # sed 's|/usr/local|/usr|g' -i "${srcdir}/${_pkgname}/build/cmake_install.cmake" || true
make DESTDIR="${pkgdir}/" install
}
diff --git a/xournalpp.install b/xournalpp.install
index 0fb20cad6369..07ef02537c55 100644
--- a/xournalpp.install
+++ b/xournalpp.install
@@ -1,12 +1,7 @@
post_install() {
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-mime-database usr/share/mime &>/dev/null
}
post_upgrade() {
- post_install
-
configs=$(find /home/ /root/ -maxdepth 2 -name ".xournalpp" 2> /dev/null)
if ! [ -z "$configs" ]; then
cat << EOF
@@ -20,5 +15,4 @@ EOF
}
post_remove() {
- post_install
}