summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchort2022-11-22 15:07:54 +0500
committerchort2022-11-22 15:07:54 +0500
commitd87f1072fc6bea052458674884ffbb252a883bbc (patch)
tree6b7a7b9775293df0c230d4dce581ef28e21ab023
downloadaur-xpathselect.tar.gz
version 1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3683a84496f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xpathselect
+ pkgdesc = Select objects in an object tree using XPath queries
+ pkgver = 1.4.15.10.20150824.1
+ pkgrel = 1
+ url = https://launchpad.net/xpathselect
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ makedepends = glibc
+ makedepends = ninja
+ makedepends = cmake
+ depends = boost
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/xpathselect_1.4+15.10.20150824.1.orig.tar.gz
+ sha512sums = SKIP
+
+pkgname = xpathselect
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c599e7fe79e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Xinc
+
+pkgname=xpathselect
+_actual_ver=1.4
+_extra_ver=+15.10.20150824.1
+pkgver=${_actual_ver}${_extra_ver/\+/.}
+pkgrel=1
+pkgdesc="Select objects in an object tree using XPath queries"
+arch=(x86_64)
+url="https://launchpad.net/xpathselect"
+license=(GPL)
+depends=(boost)
+makedepends=(gcc glibc ninja cmake)
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/xpathselect_${_actual_ver}${_extra_ver}.orig.tar.gz")
+sha512sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}-${_actual_ver}${_extra_ver}
+# Disable tests since without gtest the compiling will fail.
+ sed -i '/add_subdirectory(test)/d' CMakeLists.txt
+}
+
+build() {
+ cd ${pkgname}-${_actual_ver}${_extra_ver}
+ cmake -B build -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LOCALSTATEDIR=/var -DCMAKE_INSTALL_FULL_DATADIR=/usr/share -Wno-dev -G Ninja
+ cmake --build build
+}
+
+package() {
+ cd ${pkgname}-${_actual_ver}${_extra_ver}
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+
+