summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCam Webb2024-11-10 21:25:54 -0900
committerCam Webb2024-11-10 21:25:54 -0900
commitc2e0d427aa12dc3e1259101e243e8be3ccff4414 (patch)
treeffcde8f8cf63da5777b6bdf06ab4513006e471c2
parent502e5290f630cab4f39ad6ea362b64072d9f25e3 (diff)
downloadaur-xqilla.tar.gz
updated maintainer; changed flags to permit clean build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2203adff41c..a876e8b9b5d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = xqilla
pkgdesc = An XQuery and XPath 2.0 library, written in C++ and built on top of Xerces-C.
pkgver = 2.3.4
- pkgrel = 3
+ pkgrel = 4
url = http://xqilla.sourceforge.net/
arch = x86_64
license = GPL3
depends = xerces-c
depends = icu
+ depends = clang
source = https://downloads.sourceforge.net/project/xqilla/XQilla-2.3.4.tar.gz
sha256sums = 292631791631fe2e7eb9727377335063a48f12611d641d0296697e0c075902eb
pkgname = xqilla
-
diff --git a/PKGBUILD b/PKGBUILD
index df25fbd8f843..26afb2df88f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Daniel Biehl <dbiehl@live.de>
+# Maintainer: Cam Webb <cw@camwebb.info>
+# Contributor: Daniel Biehl <dbiehl@live.de>
# Contributor: Daniël de Kok <me@danieldk.eu>
# Contributor: Brendan Abolivier <brendan@cozycloud.cc>
pkgname=xqilla
pkgver=2.3.4
-pkgrel=3
+pkgrel=4
pkgdesc="An XQuery and XPath 2.0 library, written in C++ and built on top of Xerces-C."
arch=("x86_64")
url="http://xqilla.sourceforge.net/"
license=("GPL3")
-depends=("xerces-c" "icu")
+depends=("xerces-c" "icu" "clang")
source=("https://downloads.sourceforge.net/project/xqilla/XQilla-${pkgver}.tar.gz")
sha256sums=('292631791631fe2e7eb9727377335063a48f12611d641d0296697e0c075902eb')
@@ -19,7 +20,7 @@ prepare() {
build() {
cd "XQilla-${pkgver}"
- ./configure --prefix=/usr --with-xerces=/usr
+ LIBS=-lstdc++ CFLAGS="" CC=clang CCX=clang CXXFLAGS=-std=c++11 ./configure --prefix=/usr --with-xerces=/usr
make
}