summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2015-05-26 05:07:21 -0300
committerPablo Lezaeta Reyes2015-05-26 05:07:21 -0300
commit50a55bb450fc4606bc8d66bc76afe585a446b8c0 (patch)
tree42e015d0c45f1966905a9a1ce97d456cc936889a
downloadaur-50a55bb450fc4606bc8d66bc76afe585a446b8c0.tar.gz
theme
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore12
-rwxr-xr-x0001_Plymouth_dir.patch11
-rwxr-xr-xPKGBUILD53
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89932af39f47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = xubuntu-artwork
+ pkgdesc = Xubuntu themes and artwork
+ pkgver = 15.04.4
+ pkgrel = 3
+ url = https://launchpad.net/xubuntu-artwork
+ arch = any
+ license = GPL
+ optdepends = plymouth: For plymouth theme to work
+ optdepends = lightdm-gtk-greeter: For LightDM GTK-3 Greeter theme to work
+ optdepends = shimmer-wallpapers: Wallpapers not included in the main package
+ optdepends = xfce-theme-albatross: Official theming, git or stable versions are ok
+ optdepends = xfce-theme-bluebird: Official theming, git or stable version are ok
+ optdepends = xfce-theme-greybird: Official theming, git or stable version are ok
+ optdepends = elementary-xfce-icons: For matching icon theme, or if you want use the git version
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/xubuntu-artwork_15.04.4.tar.xz
+ source = 0001_Plymouth_dir.patch
+ md5sums = 288b5e87f7ee4e5f5d2b4f9e99f94aca
+ md5sums = c9a1b1997abf7d43dda91bf7991ed42c
+
+pkgname = xubuntu-artwork
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a2bef76a4997
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+src
+srcdir
+pkg
+pkgdir
+*.tar.*
+*.xz
+*.gz
+*.bz2
+*.tar
+*.zip
+*.rar
+*~
diff --git a/0001_Plymouth_dir.patch b/0001_Plymouth_dir.patch
new file mode 100755
index 000000000000..4dada33a6cff
--- /dev/null
+++ b/0001_Plymouth_dir.patch
@@ -0,0 +1,11 @@
+diff -Nru a/lib/plymouth/themes/xubuntu-logo/xubuntu-logo.plymouth b/lib/plymouth/themes/xubuntu-logo/xubuntu-logo.plymouth
+--- a/lib/plymouth/themes/xubuntu-logo/xubuntu-logo.plymouth 2013-04-14 01:57:37.000000000 -0400
++++ b/lib/plymouth/themes/xubuntu-logo/xubuntu-logo.plymouth 2013-05-16 14:28:25.490002514 -0400
+@@ -4,5 +4,5 @@
+ ModuleName=script
+
+ [script]
+-ImageDir=/lib/plymouth/themes/xubuntu-logo
+-ScriptFile=/lib/plymouth/themes/xubuntu-logo/xubuntu-logo.script
++ImageDir=/usr/share/plymouth/themes/xubuntu-logo
++ScriptFile=/usr/share/plymouth/themes/xubuntu-logo/xubuntu-logo.script
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..14e83b2db7dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Maintainer: Pablo Lezaeta <prflr88@gmail.com>
+
+pkgname=xubuntu-artwork
+pkgver=15.04.4
+pkgrel=3
+uver=wily
+pkgdesc="Xubuntu themes and artwork"
+arch=("any")
+url="https://launchpad.net/xubuntu-artwork"
+license=("GPL")
+#depends=("xfce-theme-albatross" "xfce-theme-bluebird" "xfce-theme-greybird" "shimmer-wallpapers")
+optdepends=("plymouth: For plymouth theme to work"
+ "lightdm-gtk-greeter: For LightDM GTK-3 Greeter theme to work"
+ "shimmer-wallpapers: Wallpapers not included in the main package"
+ "xfce-theme-albatross: Official theming, git or stable versions are ok"
+ "xfce-theme-bluebird: Official theming, git or stable version are ok"
+ "xfce-theme-greybird: Official theming, git or stable version are ok"
+ "elementary-xfce-icons: For matching icon theme, or if you want use the git version")
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}.tar.xz"
+ "0001_Plymouth_dir.patch")
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -p1 -i "${srcdir}/0001_Plymouth_dir.patch"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -dm755 "${pkgdir}/usr/"
+
+ msg2 "Install plymouth theme."
+ mkdir -p "${pkgdir}/usr/share/"
+ cp -av lib/plymouth/ "${pkgdir}/usr/share/"
+
+ msg2 "Install the rest of the files."
+ cp -av usr/share/ "${pkgdir}/usr/"
+
+ msg2 "Remove Elementary-Xfce bundled with this artwork, is seriously outdated."
+ rm -frv "${pkgdir}"/usr/share/icons
+
+ msg2 "Move backdrops to a better place for Xfce 4.12+."
+ mkdir -p "${pkgdir}/usr/share/backgrounds/xfce"
+ mv -v "${pkgdir}"/usr/share/xfce4/backdrops/* "${pkgdir}"/usr/share/backgrounds/xfce
+
+ msg2 "Remove redundant and empty files."
+ rm -frv "${pkgdir}"/usr/share/xfce4/backdrops
+}
+
+# I use MD5 because is what "makepkg -g" give by default, blame Arch dessicion
+md5sums=('288b5e87f7ee4e5f5d2b4f9e99f94aca'
+ 'c9a1b1997abf7d43dda91bf7991ed42c')