summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2021-01-01 23:25:40 +0100
committerRobbert van der Helm2021-01-01 23:25:40 +0100
commit33272175eb78976602ed305ea3defaadc477b3c8 (patch)
tree3d246545fa99bce885fedb507c86928befad8350
parentdcfe1adb80823abbd587376801dda5186380eb5f (diff)
downloadaur-33272175eb78976602ed305ea3defaadc477b3c8.tar.gz
Enable unity builds
This greatly reduces build times.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6d3ae1a48fe..5e3faa16a990 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yabridge-git
pkgdesc = Yet Another VST bridge, run Windows VST2 plugins under Linux
- pkgver = 2.2.1.r468.g775ed62
+ pkgver = 2.2.1.r492.g18bfc5c
pkgrel = 1
url = https://github.com/robbert-vdh/yabridge
install = yabridge.install
diff --git a/PKGBUILD b/PKGBUILD
index a05785708f6b..59fd0b672810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=yabridge-git
_pkgname=yabridge
-pkgver=2.2.1.r468.g775ed62
+pkgver=2.2.1.r492.g18bfc5c
pkgrel=1
pkgdesc="Yet Another VST bridge, run Windows VST2 plugins under Linux"
arch=('x86_64')
@@ -41,7 +41,15 @@ build() {
# bitbridge, then you can leave out the dependency for it and set the
# `use-bitbridge` option to false.
# You can also add `-Dwith-vst3=false` to disable building with VST3 support.
- meson setup --cross-file cross-wine.conf --buildtype=release -Dwith-bitbridge=true build
+ # If building takes up too much RAM then you can decrease the unity size or
+ # completely disable unity builds.
+ meson setup \
+ --cross-file cross-wine.conf \
+ --buildtype=release \
+ --unity=on \
+ --unity-size=1000 \
+ -Dwith-bitbridge=true \
+ build
ninja -C build
}