summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2021-02-14 17:58:58 +0100
committerRobbert van der Helm2021-02-14 17:58:58 +0100
commit5180a66649fbb35795bb1c0bf01c0e3d66008ff7 (patch)
tree72a078851ec1e5b3b1a36a5e19de5ae877c7318d
parent47d3caca77ad3a090f44a987b072f5bc4cee2680 (diff)
downloadaur-5180a66649fbb35795bb1c0bf01c0e3d66008ff7.tar.gz
Add a warning when building with Wine 6.2
The build will fail with Wine 6.2 because some of the headers are now invalid C++.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49eb6cf9583c..f15da94cdbb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yabridge-git
pkgdesc = A modern and transparent way to use Windows VST2 and VST3 plugins on Linux
pkgver = 3.0.0.r0.g8c2594f
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/robbert-vdh/yabridge
install = yabridge.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 20164e49e26d..46a71d018064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=yabridge-git
_pkgname=yabridge
pkgver=3.0.0.r0.g8c2594f
-pkgrel=1
+pkgrel=2
pkgdesc="A modern and transparent way to use Windows VST2 and VST3 plugins on Linux"
arch=('x86_64')
url="https://github.com/robbert-vdh/yabridge"
@@ -26,6 +26,23 @@ pkgver() {
build() {
cd "$_pkgname"
+ # TODO: Once this has been fixed upstream, we can remove the warning again
+ wine_version=$(wine --version | grep --only-matching -E '[0-9]+\.[0-9.]+' | head -n1)
+ if [[ $wine_version == 6.2* ]]; then
+ echo "#"
+ echo "# WARNING: Wine 6.2 has a regression that will cause build errors when"
+ echo "# compiling yabridge because the headers are no longer valid in"
+ echo "# C++. The build will likely fail. Either temporarily downgrade"
+ echo "# to a Wine 6.1 version or use the 'yabridge-bin' AUR package"
+ echo "# instead until this is fixed."
+ echo "#"
+ echo "# Continuing in five seconds..."
+ echo "#"
+
+ # Or else the message will be very easy to miss
+ sleep 5
+ fi
+
# Meson won't apply any new options or update wraps if they already exist, so
# if we're building from a dirty src/ directory we'll just nuke any cached
# files