summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2013-07-18 01:23:09 +0800
committerTing-Wei Lan2013-07-18 01:23:09 +0800
commit976ff2b99a88f3294519802b6c6650b1db4117bb (patch)
treec46aafff15a7633b4962565a59f827fbdc8050e2
parent0ce568bf40dac5dc475842503976211fab36cd46 (diff)
downloadaur-976ff2b99a88f3294519802b6c6650b1db4117bb.tar.gz
yaehmop: Fix implicit declarations
-rw-r--r--.SRCINFO4
-rw-r--r--0002-Fix-implicit-declaration.patch52
-rw-r--r--PKGBUILD9
3 files changed, 61 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e70c8bc691a..fdee18f8b730 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yaehmop
pkgdesc = Yet Another extended Huckel Molecular Orbital Package (YAeHMOP)
pkgver = 3.1.0b2
- pkgrel = 1
+ pkgrel = 2
url = http://yaehmop.sourceforge.net/
arch = x86_64
arch = i686
@@ -15,10 +15,12 @@ pkgbase = yaehmop
source = http://downloads.sourceforge.net/project/yaehmop/yaehmop-beta/3.1.0b2/viewkel.3.1.0b.tgz
source = http://downloads.sourceforge.net/project/yaehmop/yaehmop-beta/3.1.0b2/dense_eval.3.1.0b.tgz
source = 0001-Fix-build-problems.patch
+ source = 0002-Fix-implicit-declaration.patch
md5sums = 5a717a1f9c5dbe6cf36de15cb3c5b6ef
md5sums = d629bface0f610f7a4a1b3d0305872ca
md5sums = aec78fae520950777b7738cf42626d99
md5sums = 4290dcf6a1ddb040c38dbb54d8698c5b
+ md5sums = 89ecc02032067fc72a576943b9a413e7
pkgname = yaehmop
diff --git a/0002-Fix-implicit-declaration.patch b/0002-Fix-implicit-declaration.patch
new file mode 100644
index 000000000000..020fcff72080
--- /dev/null
+++ b/0002-Fix-implicit-declaration.patch
@@ -0,0 +1,52 @@
+From b6d75eb61dab7fc7921d45618244e60a82aa4769 Mon Sep 17 00:00:00 2001
+From: LAN-TW <lantw44@gmail.com>
+Date: Thu, 18 Jul 2013 00:52:58 +0800
+Subject: [PATCH] Fix implicit declaration
+
+---
+ tightbind/utils/fit_props.h | 2 ++
+ tightbind/utils/genutil.c | 2 ++
+ viewkel/dense_eval/dense_eval.c | 1 +
+ 3 files changed, 5 insertions(+)
+
+diff --git a/tightbind/utils/fit_props.h b/tightbind/utils/fit_props.h
+index 3472da8..8fd9240 100755
+--- a/tightbind/utils/fit_props.h
++++ b/tightbind/utils/fit_props.h
+@@ -4,6 +4,8 @@
+ Created by greg Landrum March 1994
+ ************************************************************************/
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <math.h>
+
+ #ifdef USING_THE_MAC
+diff --git a/tightbind/utils/genutil.c b/tightbind/utils/genutil.c
+index 2af48e2..e1aa471 100755
+--- a/tightbind/utils/genutil.c
++++ b/tightbind/utils/genutil.c
+@@ -6,6 +6,8 @@
+ *
+ *****************************************************************************/
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+
+ #define FATAL 0
+ #define ERROR 1
+diff --git a/viewkel/dense_eval/dense_eval.c b/viewkel/dense_eval/dense_eval.c
+index 9baa095..1197141 100755
+--- a/viewkel/dense_eval/dense_eval.c
++++ b/viewkel/dense_eval/dense_eval.c
+@@ -32,6 +32,7 @@
+ const char *_Version_="0.1b";
+
+ #include <stdio.h>
++#include <string.h>
+ #include <math.h>
+ #include <fcntl.h>
+
+--
+1.8.3.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 6ae0dd465dcd..5f92c2c4743a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=yaehmop
pkgver=3.1.0b2
-pkgrel=1
+pkgrel=2
pkgdesc="Yet Another extended Huckel Molecular Orbital Package (YAeHMOP)"
arch=('x86_64' 'i686')
url="http://yaehmop.sourceforge.net/"
@@ -13,12 +13,14 @@ depends=('gcc-fortran' 'readline' 'libx11' 'blas' 'lapack')
source=('http://downloads.sourceforge.net/project/yaehmop/yaehmop-beta/3.1.0b2/bind.3.1.0b2.tgz'
'http://downloads.sourceforge.net/project/yaehmop/yaehmop-beta/3.1.0b2/viewkel.3.1.0b.tgz'
'http://downloads.sourceforge.net/project/yaehmop/yaehmop-beta/3.1.0b2/dense_eval.3.1.0b.tgz'
- '0001-Fix-build-problems.patch')
+ '0001-Fix-build-problems.patch'
+ '0002-Fix-implicit-declaration.patch')
md5sums=('5a717a1f9c5dbe6cf36de15cb3c5b6ef'
'd629bface0f610f7a4a1b3d0305872ca'
'aec78fae520950777b7738cf42626d99'
- '4290dcf6a1ddb040c38dbb54d8698c5b')
+ '4290dcf6a1ddb040c38dbb54d8698c5b'
+ '89ecc02032067fc72a576943b9a413e7')
build() {
cd "${srcdir}/${pkgname}"
@@ -32,6 +34,7 @@ build() {
rm -f tightbind/utils/fit_dos.o
rm -f tightbind/utils/genutil.o
patch -p1 < ../../0001-Fix-build-problems.patch
+ patch -p1 < ../../0002-Fix-implicit-declaration.patch
cd tightbind
make -f makefile.linux install
cd ../viewkel