summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2024-03-26 00:13:43 +0900
committerAllen Zhong2024-03-26 00:13:43 +0900
commit9bf3630f4a77bd890a097d3bb6f311ccd4a2fe08 (patch)
tree4d6389f1b56b2dd488a2dbad86dd9a99b77e14db
parente98f0c62732155b5e2ddd766fc6aed280f243355 (diff)
downloadaur-yaml2json.tar.gz
bump 1.3.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a454c2349905..9d5f6f4ffbc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = yaml2json
pkgdesc = Transform yaml string to json string without the type infomation.
- pkgver = 1.3.r4.g82e774e
+ pkgver = 1.3.2
pkgrel = 1
url = https://github.com/bronze1man/yaml2json
arch = x86_64
license = MIT
makedepends = go
makedepends = git
- source = yaml2json::git+https://github.com/bronze1man/yaml2json.git
- sha256sums = SKIP
+ source = yaml2json::git+https://github.com/bronze1man/yaml2json.git#tag=v1.3.2
+ sha256sums = 60cde1335a51366b3d4f24b3e8fea258cdbbda323e41f206e8b4c9875ec1138d
pkgname = yaml2json
-
diff --git a/PKGBUILD b/PKGBUILD
index c1a7e2573c0f..b13f365091c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Maintainer: Allen Zhong <pdev@zhoal.pw>
pkgname=yaml2json
-pkgver=1.3.r4.g82e774e
+pkgver=1.3.2
pkgrel=1
pkgdesc="Transform yaml string to json string without the type infomation."
url="https://github.com/bronze1man/yaml2json"
license=('MIT')
arch=('x86_64')
makedepends=('go' 'git')
-sha256sums=('SKIP')
+sha256sums=('60cde1335a51366b3d4f24b3e8fea258cdbbda323e41f206e8b4c9875ec1138d')
source=(
- $pkgname::git+https://github.com/bronze1man/yaml2json.git
+ $pkgname::git+https://github.com/bronze1man/yaml2json.git#tag=v1.3.2
)
pkgver() {
@@ -20,15 +20,11 @@ pkgver() {
build() {
mkdir -p ${srcdir}/gobuild
export GOPATH="${srcdir}/gobuild"
- export GO111MODULE=off
-
- mv "${srcdir}/${pkgname}/vendor" "$GOPATH/src"
mkdir -p "$GOPATH/src/github.com/bronze1man"
cp -r "${srcdir}/${pkgname}" $GOPATH/src/github.com/bronze1man/yaml2json
cd "$GOPATH/src/github.com/bronze1man/yaml2json"
- #go run github.com/bronze1man/yaml2json/y2jBuilder
go install -ldflags "-s -w" -gcflags=-trimpath=$GOPATH github.com/bronze1man/yaml2json
}