diff options
author | Jisu-Woniu | 2024-01-20 16:41:29 +0800 |
---|---|---|
committer | Jisu-Woniu | 2024-01-20 16:41:29 +0800 |
commit | bcb45aa5776b6f633f7a01cb5b2f06755bb55beb (patch) | |
tree | 23e0ff96a11372eb125f4189ca0ce460b385b173 | |
parent | 982f41cb0fdba6add2376b040d965166f87b1dc0 (diff) | |
download | aur-yarn-pnpm-corepack.tar.gz |
canonicalize symlink target paths
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 9 |
2 files changed, 8 insertions, 3 deletions
@@ -1,6 +1,6 @@ pkgbase = yarn-pnpm-corepack pkgdesc = Using corepack shim to provide yarn and pnpm, while preserving npm. - pkgver = 0.1.0 + pkgver = 0.2.0 pkgrel = 1 url = https://github.com/nodejs/corepack/ install = yarn-pnpm-corepack.install @@ -1,7 +1,7 @@ # Maintainer: JisuWoniu <jswn@jswn9945.xyz> pkgname='yarn-pnpm-corepack' -pkgver=0.1.0 +pkgver=0.2.0 pkgrel=1 pkgdesc='Using corepack shim to provide yarn and pnpm, while preserving npm.' arch=('any') @@ -14,5 +14,10 @@ install=yarn-pnpm-corepack.install package() { install -dm755 "$pkgdir/usr/bin" - /usr/bin/corepack enable --install-directory "$pkgdir/usr/bin" + corepack enable --install-directory "$pkgdir/usr/bin" + + # canonicalize symlink target paths + for bin in "$pkgdir/usr/bin/"*; do + ln -sf "$(readlink -m "$bin")" "$bin" + done } |