summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2021-03-26 09:27:00 +0100
committerChristian Schendel2021-03-26 09:27:00 +0100
commitc560fc271cd0bdc3c3548af85a084e67093953d7 (patch)
tree99f43c59053934c5531c0ab16153a7675ecc1ede
parent3aa7163af7be887adb71057f51bdc87fb5afb720 (diff)
downloadaur-c560fc271cd0bdc3c3548af85a084e67093953d7.tar.gz
returning to master-branch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2c10f473f54..072c66557b2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = yaru-remix-git
- pkgdesc = Yaru-remix is a fork of Yaru theme (Gnome 3.38 branch)
- pkgver = 20.10.r0.gabfc331f
- pkgrel = 1
+ pkgdesc = Yaru-remix is a fork of Yaru theme
+ pkgver = r6.a1fdac60
+ pkgrel = 2
+ epoch = 1
url = https://github.com/Muqtxdir/yaru-remix
arch = any
license = GPL3
@@ -14,7 +15,7 @@ pkgbase = yaru-remix-git
options = !strip
options = !buildflags
options = staticlibs
- source = yaru-remix::git+https://github.com/Muqtxdir/yaru-remix.git#branch=gnome-3-38
+ source = yaru-remix::git+https://github.com/Muqtxdir/yaru-remix.git
sha256sums = SKIP
pkgname = yaru-remix-gtk-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 2bb0207b90de..cddb1c6c8a16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,24 @@ pkgname=(yaru-remix-gtk-theme-git
yaru-remix-gnome-shell-theme-git
yaru-remix-icon-theme-git
yaru-remix-wallpaper-git)
-pkgver=20.10.r0.gabfc331f
-pkgrel=1
-pkgdesc="Yaru-remix is a fork of Yaru theme (Gnome 3.38 branch)"
+pkgver=r6.a1fdac60
+pkgrel=2
+epoch=1
+pkgdesc="Yaru-remix is a fork of Yaru theme"
arch=(any)
url="https://github.com/Muqtxdir/${pkgbase%-git}"
license=('GPL3' 'LGPL3' 'LGPL2.1' 'CCPL:by-nc-sa')
makedepends=(meson sassc git)
options=('!strip' '!buildflags' 'staticlibs')
-source=("${pkgbase%-git}::git+https://github.com/Muqtxdir/yaru-remix.git#branch=gnome-3-38")
+source=("${pkgbase%-git}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgbase%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {