summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2023-02-26 09:26:23 -0500
committerAndrew O'Neill2023-02-26 09:26:23 -0500
commit17c50d66ccde7dc0e5b379e1263ff7ab9b2cf7a5 (patch)
tree9a0e11d3df428192aa84b2b35b545331a101b343
parenta71162668cfe7d3866091e259f3494af67a8405d (diff)
downloadaur-17c50d66ccde7dc0e5b379e1263ff7ab9b2cf7a5.tar.gz
Version bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43edac7c120a..ccbc18a8a6c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = yash
pkgdesc = Yet Another SHell is a POSIX-compliant command line shell
- pkgver = 2.53
+ pkgver = 2.54
pkgrel = 1
url = https://yash.osdn.jp
install = yash.install
+ arch = i686
arch = x86_64
arch = armv7h
+ arch = aarch64
license = GPL
+ makedepends = ed
depends = ncurses
- source = https://osdn.net/dl/yash/yash-2.53.tar.xz
+ options = lto
+ source = https://osdn.net/dl/yash/yash-2.54.tar.xz
source = yash.install
- sha256sums = e430ee845dfd7711c4f864d518df87dd78b40560327c494f59ccc4731585305d
+ sha256sums = 44a0ac1ccf7c3acecfbea027d8c0c930f13a828065be318055ce113015391839
sha256sums = c66c7a4b9da4416082ea57bbec0ce0c2bbc13af340ceb1241b4a4897d8944531
pkgname = yash
diff --git a/PKGBUILD b/PKGBUILD
index 3e1b4bab1d85..88dd4cb44844 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
# Contributor: Pablo Lezaeta <prflr88@gmail.com>
pkgname=yash
-pkgver=2.53
+pkgver=2.54
pkgrel=1
pkgdesc='Yet Another SHell is a POSIX-compliant command line shell'
-arch=('x86_64' 'armv7h')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url='https://yash.osdn.jp'
license=('GPL')
depends=('ncurses')
+makedepends=('ed')
+options=('lto')
install="${pkgname}.install"
source=("https://osdn.net/dl/${pkgname}/${pkgname}-${pkgver}.tar.xz"
"${pkgname}.install")
-sha256sums=('e430ee845dfd7711c4f864d518df87dd78b40560327c494f59ccc4731585305d'
+sha256sums=('44a0ac1ccf7c3acecfbea027d8c0c930f13a828065be318055ce113015391839'
'c66c7a4b9da4416082ea57bbec0ce0c2bbc13af340ceb1241b4a4897d8944531')
build() {
@@ -22,6 +24,7 @@ build() {
--prefix=/usr \
--enable-array \
--enable-dirstack \
+ --enable-double-bracket \
--enable-help \
--enable-history \
--enable-lineedit \
@@ -30,11 +33,20 @@ build() {
--enable-socket \
--enable-test \
--enable-ulimit
+
make
}
+check() {
+ cd "${pkgname}-${pkgver}"
+
+ make check
+}
+
package() {
cd "${pkgname}-${pkgver}"
make install DESTDIR="${pkgdir}"
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -r doc/* "${pkgdir}/usr/share/doc/${pkgname}"
}