summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2015-05-26 05:08:14 -0300
committerPablo Lezaeta Reyes2015-05-26 05:08:14 -0300
commit4f8b639f6671a8b6b586492240e3feeb537726c2 (patch)
treed8ad77eb2d2386388d7f0fb1c32d901a8fbc001f
downloadaur-4f8b639f6671a8b6b586492240e3feeb537726c2.tar.gz
theme 2
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore11
-rwxr-xr-xPKGBUILD31
-rwxr-xr-xyash.install11
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0eddd6dbb8f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = yash
+ pkgdesc = Yet Another SHell is a POSIX-compliant command line shell
+ pkgver = 2.37
+ pkgrel = 2
+ url = http://sourceforge.jp/projects/yash/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = pax
+ source = yash-2.37.tar.xz::http://iij.dl.sourceforge.jp/yash/62651/yash-2.37.tar.xz
+ md5sums = c119e542d58d5555d36f237c0011e83d
+
+pkgname = yash
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7d813751c966
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+src
+srcdir
+pkg
+pkgdir
+*.tar.*
+*.xz
+*.gz
+*.bz2
+*.tar
+*.zip
+*.rar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..9b056967adca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Pablo Lezaeta <prflr88@gmail.com>
+
+pkgname=yash
+pkgver=2.37
+pkgrel=2
+pkgdesc="Yet Another SHell is a POSIX-compliant command line shell"
+arch=("i686" "x86_64")
+license=("GPL2")
+url="http://sourceforge.jp/projects/yash/"
+#ToDo: Add propper deps
+makedepends=("pax")
+source=("${pkgname}-${pkgver}.tar.xz::http://iij.dl.sourceforge.jp/yash/62651/${pkgname}-${pkgver}.tar.xz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ libexecdir=/usr/lib/yash \
+ sbindir=/usr/bin libdir=/usr/lib
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make install DESTDIR=$pkgdir \
+ prefix=/usr libexecdir=/usr/lib/yash \
+ sbindir=/usr/bin libdir=/usr/lib
+}
+
+#Default to md5 as makepkg do, blame Allan McRae
+
+md5sums=('c119e542d58d5555d36f237c0011e83d')
diff --git a/yash.install b/yash.install
new file mode 100755
index 000000000000..b8ad816cd0a5
--- /dev/null
+++ b/yash.install
@@ -0,0 +1,11 @@
+post_install() {
+ grep -q '/usr/bin/yash' etc/shells || echo '/usr/bin/yash' >> etc/shells
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ sed -i '/^\/bin\/yash/d' etc/shells
+}