summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2017-12-24 22:44:42 -0500
committerAndrew O'Neill2017-12-24 22:44:42 -0500
commit90931299e0901ece1ab69b6a55027a6e962a317d (patch)
treec3a8192e6b9493a46d422716adedb90d2d166e5d
parent81906254fd5070f80ae6858ca0475993e44f319a (diff)
downloadaur-90931299e0901ece1ab69b6a55027a6e962a317d.tar.gz
Minor PKGBUILD adjustments
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93907a1c936b..b0128a8281e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = yash
pkgdesc = Yet Another SHell is a POSIX-compliant command line shell
pkgver = 2.46
- pkgrel = 1
+ pkgrel = 2
url = http://sourceforge.jp/projects/yash/
install = yash.install
- arch = i686
arch = x86_64
license = GPL
depends = ncurses
- source = https://de.osdn.net/projects/yash/downloads/68578/yash-2.46.tar.xz
+ source = https://osdn.net/dl/yash/yash-2.46.tar.xz
sha256sums = 93431d897ce2b176c9f97b879c70a426ebc125b073d5894c00cd746f3a8455cb
pkgname = yash
diff --git a/PKGBUILD b/PKGBUILD
index 1981a970700a..e2d4b69a6808 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer:
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
# Contributor: Pablo Lezaeta <prflr88@gmail.com>
pkgname=yash
pkgver=2.46
-pkgrel=1
+pkgrel=2
pkgdesc="Yet Another SHell is a POSIX-compliant command line shell"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://sourceforge.jp/projects/yash/"
license=('GPL')
depends=('ncurses')
install=yash.install
-source=("https://de.osdn.net/projects/yash/downloads/68578/yash-${pkgver}.tar.xz")
+source=("https://osdn.net/dl/$pkgname/$pkgname-$pkgver.tar.xz")
sha256sums=('93431d897ce2b176c9f97b879c70a426ebc125b073d5894c00cd746f3a8455cb')
build() {
- cd ${pkgname}-${pkgver}
+ cd $pkgname-$pkgver
+
./configure \
--prefix=/usr \
--enable-array \
@@ -31,6 +32,7 @@ build() {
}
package() {
- cd ${pkgname}-${pkgver}
- make install DESTDIR="${pkgdir}"
+ cd $pkgname-$pkgver
+
+ make install DESTDIR="$pkgdir"
}