summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 08:10:18 +1300
committercaltlgin2020-12-03 08:10:18 +1300
commitbd3b8f81317dfdb38687b41d582f6417b349bc9d (patch)
tree09f4153c38b2a631bc968519659979811f8e5329
parent079cc21c689cdaa0c611a4261e6201d699d98176 (diff)
downloadaur-yeecli.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD9
3 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce958d22ae43..2b7f1d3d6079 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = yeecli
pkgdesc = Command-line utility for controlling the YeeLight RGB LED lightbulb
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/stavros/yeecli
arch = any
license = BSD
makedepends = python-setuptools
- depends = python
depends = python-click
depends = python-ifaddr
depends = python-yeelight
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index a2076fb5f73d..477b0dcf242a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname='yeecli'
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Command-line utility for controlling the YeeLight RGB LED lightbulb'
arch=('any')
url='https://gitlab.com/stavros/yeecli'
+_url_pypi='https://pypi.org/project/yeecli'
license=('BSD')
-depends=('python' 'python-click' 'python-ifaddr' 'python-yeelight')
+depends=('python-click' 'python-ifaddr' 'python-yeelight')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('2a534273ac7997f7e3991d22153e8d17efc87d2e9ee99e6bb4acb8097206d585')
@@ -21,8 +22,8 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.rst'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: