summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2024-04-26 17:06:45 +0000
committerChristopher Arndt2024-04-26 17:06:45 +0000
commit00ca1c86ba9bd40f70813d282e09f8d7a11b19a6 (patch)
tree7af62c19f830d5b8cbf943a70f2675c4df45387b
parenta906fcd9647ffe5889ac40112f98d1655f8f51e7 (diff)
downloadaur-ykchorus.tar.gz
fix: more 'ykchorus' package fixes (#414)
* Update package description * Add missing dependencies * Don't compile in fallback audio drivers Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD10
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b513503b3e6..96890587cac6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ykchorus
- pkgdesc = A stereo dual-chorus audio effect LV2, LADSPA and VST2 plugin and JACK application
+ pkgdesc = A stereo dual-chorus audio effect CLAP/LADSPA/LV2/VST2/VST3 plugin and JACK application
pkgver = 0.2.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/SpotlightKid/ykchorus
arch = x86_64
arch = aarch64
@@ -14,8 +14,14 @@ pkgbase = ykchorus
license = GPL-2.0-only
checkdepends = kxstudio-lv2-extensions
checkdepends = lv2lint
+ makedepends = dbus
depends = gcc-libs
+ depends = glibc
depends = libglvnd
+ depends = libx11
+ depends = libxcursor
+ depends = libxext
+ depends = libxrandr
optdepends = jack: for stand-alone JACK client program
optdepends = clap-host: for CLAP plugin
optdepends = ladspa-host: for LADSPA plugin
@@ -26,3 +32,11 @@ pkgbase = ykchorus
sha256sums = 1dfd5981c52e5567eea15b43961f6bd3a88a96c0e8eabd9f56d823d24edb3970
pkgname = ykchorus
+ depends = gcc-libs
+ depends = glibc
+ depends = libglvnd
+ depends = libx11
+ depends = libxcursor
+ depends = libxext
+ depends = libxrandr
+ depends = libdbus-1.so
diff --git a/PKGBUILD b/PKGBUILD
index 7adc789d414a..7bbb4e36f623 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,13 @@
pkgname=ykchorus
_plugin_uri="https://chrisarndt.de/plugins/$pkgname"
pkgver=0.2.4
-pkgrel=2
-pkgdesc='A stereo dual-chorus audio effect LV2, LADSPA and VST2 plugin and JACK application'
+pkgrel=3
+pkgdesc='A stereo dual-chorus audio effect CLAP/LADSPA/LV2/VST2/VST3 plugin and JACK application'
arch=(x86_64 aarch64)
url="https://github.com/SpotlightKid/$pkgname"
license=(GPL-2.0-only)
-depends=(gcc-libs libglvnd)
+depends=(gcc-libs glibc libglvnd libx11 libxcursor libxext libxrandr)
+makedepends=(dbus)
checkdepends=(kxstudio-lv2-extensions lv2lint)
optdepends=(
'jack: for stand-alone JACK client program'
@@ -25,7 +26,7 @@ sha256sums=('1dfd5981c52e5567eea15b43961f6bd3a88a96c0e8eabd9f56d823d24edb3970')
build() {
cd $pkgname-$pkgver
- make
+ make SKIP_NATIVE_AUDIO_FALLBACK=true
}
check() {
@@ -34,6 +35,7 @@ check() {
}
package() {
+ depends+=(libdbus-1.so)
cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" PREFIX=/usr install
}