summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Bøe2016-05-08 22:23:04 +0200
committerSebastian Bøe2016-05-08 22:23:04 +0200
commit2f639686fc271a9177d65ee9a1aca5a9ee50eddc (patch)
treee98dbf590da55ca31a6db867e27bff9214f966d9
parentbc7276126cbec23afb68570c47577096f0fd93c2 (diff)
downloadaur-2f639686fc271a9177d65ee9a1aca5a9ee50eddc.tar.gz
Changed toolchain from clang to gcc
Seems that this PKGBUILD hasn't been following the README for quite some time, but we have been lucky and it has happened to work so far. This new release follows the installation instructions correctly by first calling make "toolchain" and then make. Also, we now use clang instead of gcc. gcc is a part of base-devel, so it makes more sense to build yosys with gcc than clang. This fixes an issue reported 2016-05-08 by cryozap.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd80326cdc60..ace02121e52a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun May 8 20:22:41 UTC 2016
pkgbase = yosys-git
pkgdesc = A framework for RTL synthesis
- pkgver = r2449.7d3a3a3
+ pkgver = r2755.5700148
pkgrel = 1
url = http://www.clifford.at/yosys/
arch = x86_64
@@ -10,7 +12,6 @@ pkgbase = yosys-git
makedepends = mercurial
depends = tcl
depends = libffi
- depends = clang
depends = python
optdepends = graphviz: Schematics display support
provides = yosys
diff --git a/PKGBUILD b/PKGBUILD
index 33743c6aa688..8a0453117a17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Sebastian Bøe <sebastianbooe at gmail dot com>
pkgname=yosys-git
-pkgrel=2
-pkgver=r2449.7d3a3a3
+pkgrel=1
+pkgver=r2755.5700148
pkgdesc='A framework for RTL synthesis'
arch=('x86_64' 'i686')
url='http://www.clifford.at/yosys/'
license=('custom:ISC')
provides=("yosys")
conflicts=("yosys")
-depends=('tcl' 'libffi' 'clang' 'python')
+depends=('tcl' 'libffi' 'python')
optdepends=('graphviz: Schematics display support')
makedepends=('git' 'mercurial')
source=('git+https://github.com/cliffordwolf/yosys.git'
@@ -19,6 +19,7 @@ sha512sums=('SKIP'
build(){
cd ${srcdir}/yosys
+ make config-gcc
make
}