summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Lloyd2019-06-26 20:29:44 -0700
committerPatrick Lloyd2019-06-26 20:29:44 -0700
commit5b36942159df095956c4e35c513cdf62905608c7 (patch)
tree3e734d5452fe9ca0707a498f88fe0562219ed8f7
parent877d5051e00997c669978663d94195a0f0d8c5c9 (diff)
downloadaur-5b36942159df095956c4e35c513cdf62905608c7.tar.gz
enabled python dependency and regenerated srcinfo
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34460283f19b..6f0491880bcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yosys-git
pkgdesc = A framework for RTL synthesis
- pkgver = r4323.266511b2
+ pkgver = r5298.0d2b87e3
pkgrel = 1
url = http://www.clifford.at/yosys/
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = yosys-git
depends = tcl
depends = libffi
depends = python
- depends = xdot
optdepends = graphviz: Schematics display support
+ optdepends = xdot: Design netlist display support
provides = yosys
conflicts = yosys
source = git+https://github.com/cliffordwolf/yosys.git
diff --git a/PKGBUILD b/PKGBUILD
index 14cce2482abb..013b61d2532d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=yosys-git
pkgrel=1
-pkgver=r4323.266511b2
+pkgver=r5298.0d2b87e3
pkgdesc='A framework for RTL synthesis'
arch=('x86_64' 'i686')
url='http://www.clifford.at/yosys/'
@@ -25,6 +25,8 @@ build(){
cd ${srcdir}/yosys
mv ../abc ./
make config-gcc
+ echo "ENABLE_LIBYOSYS=1" >> Makefile.conf
+ echo "ENABLE_PYOSYS=1" >> Makefile.conf
make
}
@@ -35,7 +37,7 @@ pkgver() {
package() {
cd ${srcdir}/yosys
- make PREFIX=$pkgdir/usr/ install
+ make PREFIX=$pkgdir/usr/ PYTHON_PREFIX=$pkgdir/usr/ install
install -D -m 644 \
"${srcdir}/LICENSE" \