summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Biereigel2020-03-12 18:08:51 +0100
committerStefan Biereigel2020-03-12 18:08:51 +0100
commitea6ccdfa28c88250d51058f28acdd33223d1ae92 (patch)
tree5787bf7ee7b1b0cd5f689059fb85f9870431d729
parentbc620cb2832f94693e91c8aeab27e4770f1b12c0 (diff)
downloadaur-ea6ccdfa28c88250d51058f28acdd33223d1ae92.tar.gz
incorporate changes provided by xiretza
-rw-r--r--.SRCINFO6
-rw-r--r--LICENSE15
-rw-r--r--PKGBUILD48
3 files changed, 35 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03254bb53dc0..77dc0dc861ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = yosys-git
pkgdesc = A framework for RTL synthesis
- pkgver = r8603.2ce7a0d3
+ pkgver = r8895.af84e5ac
pkgrel = 1
url = http://www.clifford.at/yosys/
arch = x86_64
arch = i686
license = custom:ISC
+ checkdepends = iverilog
+ checkdepends = clang
makedepends = git
makedepends = mercurial
makedepends = boost
@@ -19,10 +21,8 @@ pkgbase = yosys-git
conflicts = yosys
source = git+https://github.com/cliffordwolf/yosys.git
source = git+https://github.com/berkeley-abc/abc.git
- source = LICENSE
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = a3202289ff7828c55d3ec3e22d23ed78a34fcae165a7c666d71d3cedd9abe06f638a09750d8c2d43dfca5781f1b32a616f439c3713a12265c02473f88c0f426d
pkgname = yosys-git
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index d5b50f7fcf44..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,15 +0,0 @@
-yosys -- Yosys Open SYnthesis Suite
-
-Copyright (C) 2012 - 2015 Clifford Wolf <clifford@clifford.at>
-
-Permission to use, copy, modify, and/or distribute this software for any
-purpose with or without fee is hereby granted, provided that the above
-copyright notice and this permission notice appear in all copies.
-
-THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
-WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
-MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
-ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
-ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
-OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index eace4f33a146..370096b9b444 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Stefan Biereigel <$(base64 --decode <<<'c3RlZmFuQGJpZXJlaWdlbC5kZQo=')>
+# Contributor: xiretza <xiretza+aur@gmail.com>
# Contributor: Patrick Lloyd <$(base64 --decode <<<'cGF0cmlja0BsbG95ZC5zaAo=')>
# Contributor: Sebastian Bøe <$(base64 --decode <<<'c2ViYXN0aWFuYm9vZUBnbWFpbC5jb20K')>
# Contributor: Darren Wu <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
pkgname=yosys-git
pkgrel=1
-pkgver=r8603.2ce7a0d3
+pkgver=r8895.af84e5ac
pkgdesc='A framework for RTL synthesis'
arch=('x86_64' 'i686')
url='http://www.clifford.at/yosys/'
@@ -15,32 +16,47 @@ conflicts=("yosys")
depends=('tcl' 'libffi' 'python' 'boost-libs')
optdepends=('graphviz: Schematics display support' 'xdot: Design netlist display support')
makedepends=('git' 'mercurial' 'boost')
+checkdepends=('iverilog' 'clang')
source=('git+https://github.com/cliffordwolf/yosys.git'
- 'git+https://github.com/berkeley-abc/abc.git'
- 'LICENSE')
+ 'git+https://github.com/berkeley-abc/abc.git')
+
sha512sums=('SKIP'
- 'SKIP'
- 'a3202289ff7828c55d3ec3e22d23ed78a34fcae165a7c666d71d3cedd9abe06f638a09750d8c2d43dfca5781f1b32a616f439c3713a12265c02473f88c0f426d')
+ 'SKIP')
+
+pkgver() {
+ cd "${srcdir}/yosys"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/abc"
+ git checkout "$(make --silent -C "${srcdir}/yosys" echo-abc-rev)"
+}
+
+build() {
+ cd "${srcdir}/yosys"
+
+ ln -s "${srcdir}/abc/" .
-build(){
- cd ${srcdir}/yosys
- mv ../abc ./
make config-gcc
echo "ENABLE_LIBYOSYS=1" >> Makefile.conf
echo "ENABLE_PYOSYS=1" >> Makefile.conf
+ echo "ABCPULL=0" >> Makefile.conf
+
make PREFIX="/usr"
}
-pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+check() {
+ cd "${srcdir}/yosys"
+
+ make test
}
package() {
- cd ${srcdir}/yosys
- make PREFIX="/usr" PYTHON_PREFIX="$pkgdir/usr" DESTDIR="$pkgdir" install
+ cd "${srcdir}/yosys"
+
+ # disable stripping in the makefile - duplicated effort and makes debug packages impossible
+ make STRIP=':' PREFIX="/usr" PYTHON_PREFIX="${pkgdir}/usr" DESTDIR="${pkgdir}" install
- install -D -m 644 \
- "${srcdir}/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}