summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Dowsett2024-01-22 20:03:32 +0800
committerNick Dowsett2024-01-22 20:03:32 +0800
commit96e416051da6d06809262330beb7bdce1135c037 (patch)
treeeb447a76cd3f47fd5c75da238a7d6c1d46040317
downloadaur-youtui.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c085fd4e083b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = youtui
+ pkgdesc = A simple TUI YouTube Music player written in Rust aiming to implement an Artist->Albums workflow for searching for music, and using discoverability principles for navigation. Writtten in Rust.
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/nick42d/youtui
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ depends = alsa-lib
+ depends = openssl
+ source = youtui-0.0.4.tar.gz::https://static.crates.io/crates/youtui/youtui-0.0.4.crate
+ sha256sums = ccd55ed8eb9995f8be06dedbbf589f337842d40dfe87a12ea5131eacd852e6a5
+
+pkgname = youtui
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b083324af76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Nick Dowsett <nickdowsett42@gmail.com>
+
+pkgname=youtui
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="A simple TUI YouTube Music player written in Rust aiming to implement an Artist->Albums workflow for searching for music, and using discoverability principles for navigation. Writtten in Rust."
+url="https://github.com/nick42d/youtui"
+arch=('x86_64' 'armv7h' 'aarch64')
+license=('MIT')
+depends=('alsa-lib' 'openssl')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+sha256sums=('ccd55ed8eb9995f8be06dedbbf589f337842d40dfe87a12ea5131eacd852e6a5')
+
+prepare() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+
+build() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm0644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+}