summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2022-06-14 01:42:22 -0400
committerBrendan Szymanski2022-06-14 01:42:22 -0400
commit11a4f4f2833ee8e21f5ac81328f15fe6fd6da134 (patch)
tree33f487c7881448eaab097588e23193a0713651a1
parenta79a23172cb348661d20e9752106629210b4fb0a (diff)
downloadaur-11a4f4f2833ee8e21f5ac81328f15fe6fd6da134.tar.gz
Removed GCC/Clang patch, as it is no longer necessary
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD28
-rwxr-xr-xyuzu-gcc12-clang13.patch11
3 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9100b397bfb8..0c2270a6a1ad 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch
- pkgver = r21473.4ae75bec5
+ pkgver = r21515.bd3bfe411
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu
arch = i686
@@ -55,7 +55,6 @@ pkgbase = yuzu-git
source = git+https://github.com/yhirose/cpp-httplib.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
- source = yuzu-gcc12-clang13.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
@@ -73,6 +72,5 @@ pkgbase = yuzu-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 0c60d6dae4ae6c5f33c944c584a5a7dc
pkgname = yuzu-git
diff --git a/PKGBUILD b/PKGBUILD
index cf904c58a0e9..f4a4b23c1be8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-git
-pkgver=r21473.4ae75bec5
+pkgver=r21515.bd3bfe411
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch'
arch=('i686' 'x86_64')
@@ -57,8 +57,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
# sirit dependencies
- 'git+https://github.com/KhronosGroup/SPIRV-Headers.git'
- 'yuzu-gcc12-clang13.patch')
+ 'git+https://github.com/KhronosGroup/SPIRV-Headers.git')
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -75,8 +74,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '0c60d6dae4ae6c5f33c944c584a5a7dc')
+ 'SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -107,9 +105,6 @@ prepare() {
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
git submodule update --init
done
-
- cd "$srcdir/$_pkgname"
- patch -p1 < ../yuzu-gcc12-clang13.patch
}
build() {
@@ -150,3 +145,20 @@ package() {
cd "$srcdir/$_pkgname/build"
DESTDIR="$pkgdir" ninja install
}
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
diff --git a/yuzu-gcc12-clang13.patch b/yuzu-gcc12-clang13.patch
deleted file mode 100755
index 8041bbe71afc..000000000000
--- a/yuzu-gcc12-clang13.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/shader_recompiler/frontend/maxwell/structured_control_flow.cpp
-+++ b/src/shader_recompiler/frontend/maxwell/structured_control_flow.cpp
-@@ -977,7 +977,7 @@ private:
- bool uses_demote_to_helper{};
-
- // TODO: C++20 Remove this when all compilers support constexpr std::vector
--#if __cpp_lib_constexpr_vector >= 201907
-+#if (__cpp_lib_constexpr_vector >= 201907) && !(defined(__clang__)) && !(defined(__GNUC__))
- static constexpr Flow::Block dummy_flow_block;
- #else
- const Flow::Block dummy_flow_block;