summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2021-10-05 17:04:20 -0400
committerBrendan Szymanski2021-10-05 17:04:20 -0400
commit52d1dafd37da6db085f7948c4531a393eb8dd214 (patch)
treeb78c66950d02f3dfdc3485eb26927e668add1a63
parentc8661ae69aae02a73f03e691193c44980c170944 (diff)
downloadaur-52d1dafd37da6db085f7948c4531a393eb8dd214.tar.gz
Remove libzip, enable external SDL
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD9
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95677a2071e8..ed8fa73fa6c9 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch
- pkgver = r19504.3843995ce
+ pkgver = r19743.5b2fa8dd4
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu
arch = i686
@@ -47,7 +47,6 @@ pkgbase = yuzu-git
source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = git+https://github.com/ReinUsesLisp/sirit
source = git+https://github.com/yuzu-emu/mbedtls
- source = git+https://github.com/nih-at/libzip.git
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/xiph/opus.git
source = git+https://git.ffmpeg.org/ffmpeg.git
@@ -73,6 +72,5 @@ pkgbase = yuzu-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = SKIP
pkgname = yuzu-git
diff --git a/PKGBUILD b/PKGBUILD
index 40929a07840b..723fe5e8f0f4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-git
-pkgver=r19504.3843995ce
+pkgver=r19743.5b2fa8dd4
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch'
arch=('i686' 'x86_64')
@@ -48,7 +48,6 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/KhronosGroup/Vulkan-Headers.git'
'git+https://github.com/ReinUsesLisp/sirit'
'git+https://github.com/yuzu-emu/mbedtls'
- 'git+https://github.com/nih-at/libzip.git'
'git+https://github.com/herumi/xbyak.git'
'git+https://github.com/xiph/opus.git'
'git+https://git.ffmpeg.org/ffmpeg.git'
@@ -75,7 +74,6 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -86,7 +84,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,libzip/libzip,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
+ for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
git submodule update
@@ -119,9 +117,10 @@ build() {
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DENABLE_QT_TRANSLATION=ON \
-DYUZU_USE_QT_WEB_ENGINE=ON \
+ -DYUZU_USE_EXTERNAL_SDL2=OFF \
-DUSE_DISCORD_PRESENCE=ON \
+ -DENABLE_QT_TRANSLATION=ON \
-DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON
make
}