summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZion Nimchuk2018-08-03 13:48:13 -0700
committerZion Nimchuk2018-08-03 13:50:58 -0700
commit83595b8dc0b873288acf138910255e8ec08f250b (patch)
treebd11901d4ffb51910624c06e73eae7f424dcae36
parent9c91d9cbd8baeb60c963d37b74c2df3406af56cf (diff)
downloadaur-83595b8dc0b873288acf138910255e8ec08f250b.tar.gz
Fix build and workaround cubeb cmake
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD40
2 files changed, 34 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df95340cf6a5..15065346722a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r5919.5750f6f0
+ pkgver = r7580.29f31356
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu/
arch = i686
@@ -22,6 +22,12 @@ pkgbase = yuzu-git
source = git+https://github.com/svn2github/inih
source = git+https://github.com/yuzu-emu/unicorn
source = git+https://github.com/lz4/lz4
+ source = git+https://github.com/ogniK5377/opus
+ source = git+https://github.com/kinetiknz/cubeb
+ source = git+https://github.com/arsenm/sanitizers-cmake
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1a6c58bd95b4..17d80be95722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgbase='yuzu'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r5919.5750f6f0
+pkgver=r7580.29f31356
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
@@ -17,7 +17,11 @@ source=("$_pkgbase::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/fmtlib/fmt'
'git+https://github.com/svn2github/inih'
'git+https://github.com/yuzu-emu/unicorn'
- 'git+https://github.com/lz4/lz4')
+ 'git+https://github.com/lz4/lz4'
+ 'git+https://github.com/ogniK5377/opus'
+ 'git+https://github.com/kinetiknz/cubeb'
+ # cubeb submodule dependencies
+ 'git+https://github.com/arsenm/sanitizers-cmake')
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -26,6 +30,9 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -36,7 +43,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgbase"
mkdir -p build
-
+
git submodule init
git config submodule.boost.url "$srcdir/ext-boost"
git config submodule.catch.url "$srcdir/Catch"
@@ -45,12 +52,14 @@ prepare() {
git config submodule.fmt.url "$srcdir/fmt"
git config submodule.inih.url "$srcdir/inih"
git config submodule.unicorn.url "$srcdir/unicorn"
- git config submodule.lz4.url "$srcdir/lz4"
+ git config submodule.opus.url "$srcdir/opus"
+ git config submodule.cubeb.url "$srcdir/cubeb"
git submodule update
+
- cd externals/dynarmic
- git config submodule.externals/fmt.url "$srcdir/fmt"
- git config submodule.externals/xbyak.url "$srcdir/xbyak"
+
+ cd externals/cubeb
+ git config submodule.cmake/sanitizers-cmake.url "$srcdir/sanitizers-cmake"
git submodule update
}
@@ -58,15 +67,11 @@ build() {
cd "$srcdir/$_pkgbase/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTS=False
make
}
-check() {
- cd "$srcdir/$_pkgbase/build"
- make test
-}
-
package_yuzu-git() {
depends=('sdl2' 'libpng')
@@ -79,6 +84,15 @@ package_yuzu-qt-git() {
'qt5-wayland: for Wayland support')
cd "$srcdir/$_pkgbase/build"
+
+ # screw cubeb and it's shitty cmake
+ mkdir -p "$srcdir/$_pkgbase/include/cubeb"
+
make DESTDIR="$pkgdir/" install
+
+ # screw cubeb cmake even more
+ rm -r "$pkgdir/usr/lib64"
+ rm -r "$pkgdir/usr/include"
+
rm "$pkgdir/usr/bin/${_pkgbase}-cmd"
}