summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-01 22:47:59 -0800
committerxiota2023-12-01 22:47:59 -0800
commit8daa1f3b57723f018d6be838245917a9ea6e336f (patch)
tree25b6ab14cd5b978dbd426ff1a534cb83776283e9
parent10f0b5c01b8bc492013e1fcc762f7cf3236300b5 (diff)
downloadaur-8daa1f3b57723f018d6be838245917a9ea6e336f.tar.gz
r26003.e9a43bae6
update submodules
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cff6422b532e..c630c1f8718f 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch
- pkgver = r25899.093eb075a
+ pkgver = r26003.e9a43bae6
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu
arch = i686
@@ -30,7 +30,7 @@ pkgbase = yuzu-git
conflicts = yuzu
source = yuzu::git+https://github.com/yuzu-emu/yuzu.git
source = arun11299.cpp-jwt::git+https://github.com/arun11299/cpp-jwt.git
- source = benhoyt.inih::git+https://github.com/benhoyt/inih.git
+ source = brofield.simpleini::git+https://github.com/brofield/simpleini.git
source = bylaws.libadrenotools::git+https://github.com/bylaws/libadrenotools.git
source = ffmpeg::git+https://github.com/FFmpeg/FFmpeg.git
source = gpuopen-librariesandsdks.vulkanmemoryallocator::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
@@ -41,6 +41,7 @@ pkgbase = yuzu-git
source = libusb::git+https://github.com/libusb/libusb.git
source = lsalzman.enet::git+https://github.com/lsalzman/enet.git
source = merryhime.dynarmic::git+https://github.com/merryhime/dynarmic.git
+ source = merryhime.oaknut::git+https://github.com/merryhime/oaknut.git
source = microsoft.vcpkg::git+https://github.com/microsoft/vcpkg.git
source = mozilla.cubeb::git+https://github.com/mozilla/cubeb.git
source = xiph.opus::git+https://github.com/xiph/opus.git
@@ -80,5 +81,6 @@ pkgbase = yuzu-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = yuzu-git
diff --git a/PKGBUILD b/PKGBUILD
index 40b42baafc79..42d4761b182c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# basic info
_pkgname="yuzu"
pkgname="$_pkgname${_pkgtype:+-$_pkgtype}"
-pkgver=r25899.093eb075a
+pkgver=r26003.e9a43bae6
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch'
url="https://github.com/yuzu-emu/yuzu"
@@ -26,7 +26,6 @@ _main_package() {
#'cubeb'
#'enet'
- #'libinih'
#'mbedtls'
)
makedepends=(
@@ -76,7 +75,7 @@ _main_package() {
_source_yuzu() {
source+=(
'arun11299.cpp-jwt'::'git+https://github.com/arun11299/cpp-jwt.git'
- 'benhoyt.inih'::'git+https://github.com/benhoyt/inih.git'
+ 'brofield.simpleini'::'git+https://github.com/brofield/simpleini.git'
'bylaws.libadrenotools'::'git+https://github.com/bylaws/libadrenotools.git'
'ffmpeg'::'git+https://github.com/FFmpeg/FFmpeg.git'
'gpuopen-librariesandsdks.vulkanmemoryallocator'::'git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git'
@@ -87,6 +86,7 @@ _source_yuzu() {
'libusb'::'git+https://github.com/libusb/libusb.git'
'lsalzman.enet'::'git+https://github.com/lsalzman/enet.git'
'merryhime.dynarmic'::'git+https://github.com/merryhime/dynarmic.git'
+ 'merryhime.oaknut'::'git+https://github.com/merryhime/oaknut.git'
'microsoft.vcpkg'::'git+https://github.com/microsoft/vcpkg.git'
'mozilla.cubeb'::'git+https://github.com/mozilla/cubeb.git'
'xiph.opus'::'git+https://github.com/xiph/opus.git'
@@ -117,13 +117,14 @@ _source_yuzu() {
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
_prepare_yuzu() (
cd "${srcdir:?}/$_pkgsrc"
local -A _submodules=(
['arun11299.cpp-jwt']='externals/cpp-jwt'
- ['benhoyt.inih']='externals/inih/inih'
+ ['brofield.simpleini']='externals/simpleini'
['bylaws.libadrenotools']='externals/libadrenotools'
['ffmpeg']='externals/ffmpeg/ffmpeg'
['gpuopen-librariesandsdks.vulkanmemoryallocator']='externals/VulkanMemoryAllocator'
@@ -134,6 +135,7 @@ _source_yuzu() {
['libusb']='externals/libusb/libusb'
['lsalzman.enet']='externals/enet'
['merryhime.dynarmic']='externals/dynarmic'
+ ['merryhime.oaknut']='externals/oaknut'
['microsoft.vcpkg']='externals/vcpkg'
['mozilla.cubeb']='externals/cubeb'
['xiph.opus']='externals/opus'