summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZion Nimchuk2023-05-07 23:27:28 -0700
committerZion Nimchuk2023-05-07 23:27:28 -0700
commitbce6d922889e5e651eab68e527291d52171327c1 (patch)
treed98744ce226030cfe549b84a2682a38f8b59cb3b
parent0e89a3fa9583f4f830e0c1211cde05b246423cd0 (diff)
downloadaur-bce6d922889e5e651eab68e527291d52171327c1.tar.gz
Update source dependencies, add qt multimedia to cmake params
-rwxr-xr-x.SRCINFO15
-rwxr-xr-xPKGBUILD39
2 files changed, 31 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd7e6a3633b1..42d7bca459be 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -37,24 +37,26 @@ pkgbase = yuzu-git
depends = zstd
provides = yuzu
provides = yuzu-cmd
- conflicts = yuzu-mainline-git
- conflicts = yuzu-canary-git
+ conflicts = yuzu
source = yuzu::git+https://github.com/yuzu-emu/yuzu
+ source = git+https://github.com/lsalzman/enet.git
source = git+https://github.com/benhoyt/inih.git
source = git+https://github.com/kinetiknz/cubeb.git
source = git+https://github.com/MerryMage/dynarmic.git
- source = libressl::git+https://github.com/citra-emu/ext-libressl-portable.git
source = git+https://github.com/libusb/libusb.git
- source = git+https://github.com/discord/discord-rpc.git
+ source = git+https://github.com/yuzu-emu/discord-rpc.git
source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
- source = git+https://github.com/ReinUsesLisp/sirit
+ source = git+https://github.com/yuzu-emu/sirit
source = git+https://github.com/yuzu-emu/mbedtls
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/xiph/opus.git
source = git+https://git.ffmpeg.org/ffmpeg.git
source = git+https://github.com/libsdl-org/SDL.git
source = git+https://github.com/yhirose/cpp-httplib.git
+ source = git+https://github.com/Microsoft/vcpkg.git
+ source = git+https://github.com/arun11299/cpp-jwt.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
+ source = git+https://github.com/google/googletest
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
md5sums = SKIP
md5sums = SKIP
@@ -73,5 +75,8 @@ pkgbase = yuzu-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-git
diff --git a/PKGBUILD b/PKGBUILD
index b1ff3154b9b4..2893cf3bdde5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,22 +41,25 @@ makedepends=('boost'
'robin-map'
'yasm')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
+ 'git+https://github.com/lsalzman/enet.git'
'git+https://github.com/benhoyt/inih.git'
'git+https://github.com/kinetiknz/cubeb.git'
'git+https://github.com/MerryMage/dynarmic.git'
- 'git+https://github.com/lsalzman/enet.git'
'git+https://github.com/libusb/libusb.git'
- 'git+https://github.com/discord/discord-rpc.git'
+ 'git+https://github.com/yuzu-emu/discord-rpc.git'
'git+https://github.com/KhronosGroup/Vulkan-Headers.git'
- 'git+https://github.com/yuzu-emu/sirit.git'
- 'git+https://github.com/yuzu-emu/mbedtls.git'
+ 'git+https://github.com/yuzu-emu/sirit'
+ 'git+https://github.com/yuzu-emu/mbedtls'
'git+https://github.com/herumi/xbyak.git'
'git+https://github.com/xiph/opus.git'
'git+https://git.ffmpeg.org/ffmpeg.git'
'git+https://github.com/libsdl-org/SDL.git'
'git+https://github.com/yhirose/cpp-httplib.git'
+ 'git+https://github.com/Microsoft/vcpkg.git'
+ 'git+https://github.com/arun11299/cpp-jwt.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
+ 'git+https://github.com/google/googletest'
# sirit dependencies
'git+https://github.com/KhronosGroup/SPIRV-Headers.git')
md5sums=('SKIP'
@@ -75,6 +78,9 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -85,27 +91,23 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in externals/{inih/inih,cubeb,dynarmic,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update --init
+ for submodule in {inih,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet};
+ do
+ git config --file=.gitmodules submodule.$submodule.url "$srcdir/${submodule}"
done
+ git -c protocol.file.allow=always submodule update --init
+
cd "$srcdir/$_pkgname"/externals/cubeb
- for submodule in cmake/sanitizers-cmake; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update --init
- done
+ git config --file=.gitmodules submodule.cmake/sanitizers-cmake.url "$srcdir/sanitizers-cmake"
+ git config --file=.gitmodules submodule.googletest.url "$srcdir/googletest"
+ git -c protocol.file.allow=always submodule update --init
cd "$srcdir/$_pkgname"/externals/sirit
- for submodule in externals/SPIRV-Headers; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
- git submodule update --init
- done
+ git config --file=.gitmodules submodule.externals/SPIRV-Headers.url "$srcdir/SPIRV-Headers"
+ git -c protocol.file.allow=always submodule update --init
}
build() {
@@ -121,6 +123,7 @@ build() {
-DCMAKE_CXX_COMPILER=clang++ \
-DCMAKE_BUILD_TYPE=Release \
-DYUZU_USE_QT_WEB_ENGINE=ON \
+ -DYUZU_USE_QT_MULTIMEDIA=ON \
-DYUZU_USE_EXTERNAL_SDL2=OFF \
-DUSE_DISCORD_PRESENCE=ON \
-DENABLE_QT_TRANSLATION=ON \