summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-06-06 21:56:44 -0500
committerHurricanePootis2023-06-06 21:56:44 -0500
commit2ad29b8c3aa4cd95ab9b2e97983e6478a49852a7 (patch)
tree4922a113f15ee73732149916583c510bd86b8d07
parenta317c6fe8d2a0cb51ef9d4b71193f55141e5a708 (diff)
downloadaur-2ad29b8c3aa4cd95ab9b2e97983e6478a49852a7.tar.gz
Add libadreno and liblinkernsbypass to yuzu-maineline-git
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD14
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f83825b23a53..62b2fe0203a9 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = r23801.fbe86b889
+ pkgver = r24266.069d7e6be
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -54,9 +54,13 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/yhirose/cpp-httplib.git
source = git+https://github.com/Microsoft/vcpkg.git
source = git+https://github.com/arun11299/cpp-jwt.git
+ source = git+https://github.com/bylaws/libadrenotools.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/google/googletest
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
+ source = git+https://github.com/bylaws/liblinkernsbypass.git
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b9bc5e670e03..1c2c2b88f4a6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r23801.fbe86b889
+pkgver=r24266.069d7e6be
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -54,11 +54,14 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/yhirose/cpp-httplib.git'
'git+https://github.com/Microsoft/vcpkg.git'
'git+https://github.com/arun11299/cpp-jwt.git'
+ 'git+https://github.com/bylaws/libadrenotools.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
'git+https://github.com/google/googletest'
# sirit dependencies
- 'git+https://github.com/KhronosGroup/SPIRV-Headers.git')
+ 'git+https://github.com/KhronosGroup/SPIRV-Headers.git'
+ # libadrenotools' dependencies
+ 'git+https://github.com/bylaws/liblinkernsbypass.git')
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -79,6 +82,8 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -93,6 +98,7 @@ prepare() {
do
git config --file=.gitmodules submodule.$submodule.url "$srcdir/${submodule}"
done
+ git config --file=.gitmodules submodule.externals/libadrenotools.url "$srcdir/libadrenotools"
git -c protocol.file.allow=always submodule update --init
@@ -106,6 +112,10 @@ prepare() {
git config --file=.gitmodules submodule.externals/SPIRV-Headers.url "$srcdir/SPIRV-Headers"
git -c protocol.file.allow=always submodule update --init
+
+ cd "$srcdir/$_pkgname/externals/libadrenotools"
+ git config --file=.gitmodules submodule.lib/linkernsbypass.url "$srcdir/liblinkernsbypass"
+ git -c protocol.file.allow=always submodule update --init
}
build() {