summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-05-22 17:51:10 -0500
committerHurricanePootis2023-05-22 17:51:10 -0500
commit2b20b5c8edeee7eaef3d4bd4414c5b407ce4f3e7 (patch)
treef9ef14cf13eaaa5d9fcef0a438f778d391e4bd7a
parent4169dd93062a421658eed8e694de6d3770308ece (diff)
downloadaur-2b20b5c8edeee7eaef3d4bd4414c5b407ce4f3e7.tar.gz
Update submodules and go back to clang
-rwxr-xr-x.SRCINFO8
-rwxr-xr-xPKGBUILD16
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e49bd5debfd..197ee0c578cd 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = r23626.2506594c5
+ pkgver = r23770.f82efe9f6
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -9,7 +9,7 @@ pkgbase = yuzu-mainline-git
makedepends = boost
makedepends = llvm
makedepends = catch2
- makedepends = gcc
+ makedepends = clang
makedepends = cmake
makedepends = ffmpeg
makedepends = git
@@ -38,14 +38,14 @@ pkgbase = yuzu-mainline-git
source = yuzu::git+https://github.com/yuzu-emu/yuzu-mainline
source = git+https://github.com/lsalzman/enet.git
source = git+https://github.com/benhoyt/inih.git
- source = git+https://github.com/kinetiknz/cubeb.git
+ source = git+https://github.com/mozilla/cubeb.git
source = git+https://github.com/MerryMage/dynarmic.git
source = libressl::git+https://github.com/citra-emu/ext-libressl-portable.git
source = git+https://github.com/libusb/libusb.git
source = git+https://github.com/yuzu-emu/discord-rpc.git
source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = git+https://github.com/yuzu-emu/sirit
- source = git+https://github.com/yuzu-emu/mbedtls
+ source = git+https://github.com/yuzu-emu/mbedtls.git
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/xiph/opus.git
source = git+https://git.ffmpeg.org/ffmpeg.git
diff --git a/PKGBUILD b/PKGBUILD
index c500080595b4..0b29f0d97f7c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r23626.2506594c5
+pkgver=r23770.f82efe9f6
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -25,7 +25,7 @@ depends=('fmt'
makedepends=('boost'
'llvm'
'catch2'
- 'gcc'
+ 'clang'
'cmake'
'ffmpeg'
'git'
@@ -38,14 +38,14 @@ optdepends=("qt5-wayland: Wayland support")
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/lsalzman/enet.git'
'git+https://github.com/benhoyt/inih.git'
- 'git+https://github.com/kinetiknz/cubeb.git'
+ 'git+https://github.com/mozilla/cubeb.git'
'git+https://github.com/MerryMage/dynarmic.git'
'libressl::git+https://github.com/citra-emu/ext-libressl-portable.git'
'git+https://github.com/libusb/libusb.git'
'git+https://github.com/yuzu-emu/discord-rpc.git'
'git+https://github.com/KhronosGroup/Vulkan-Headers.git'
'git+https://github.com/yuzu-emu/sirit'
- 'git+https://github.com/yuzu-emu/mbedtls'
+ 'git+https://github.com/yuzu-emu/mbedtls.git'
'git+https://github.com/herumi/xbyak.git'
'git+https://github.com/xiph/opus.git'
'git+https://git.ffmpeg.org/ffmpeg.git'
@@ -115,10 +115,10 @@ build() {
cmake -S $_pkgname -B build \
-GNinja \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_C_COMPILER=gcc \
- -DCMAKE_CXX_COMPILER=g++ \
- -DCMAKE_C_FLAGS="$CFLAGS -flto=auto" \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS -flto=auto" \
+ -DCMAKE_C_COMPILER=clang \
+ -DCMAKE_CXX_COMPILER=clang++ \
+ -DCMAKE_C_FLAGS="$CFLAGS -flto=thin" \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -flto=thin" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DYUZU_USE_QT_WEB_ENGINE=ON \
-DYUZU_USE_QT_MULTIMEDIA=ON \