summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2020-02-07 21:56:39 -0500
committerBrendan Szymanski2020-02-07 21:56:39 -0500
commit3a1738b03bc77054f539089d1872ed2abb09b8c3 (patch)
tree8834b9d9fcfcc146e5d26e91506caddb15ce8bb8
parent7c4c6056036dada0fcf3a3ab4f97acf0bcc826c2 (diff)
downloadaur-3a1738b03bc77054f539089d1872ed2abb09b8c3.tar.gz
Add SDL exception fix
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aac117a5403c..7f8d8d57c1ca 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r13523.d47960cf3
+ pkgver = r13623.e0cf27650
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index d612fdf2fa4a..789665954fd6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r13523.d47960cf3
+pkgver=r13623.e0cf27650
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
@@ -40,6 +40,12 @@ build() {
# Hopefully temporary fix for a compilation error involving fmt
CXXFLAGS+=" -DFMT_USE_USER_DEFINED_LITERALS=0"
+ # Flag to disable pre-compiled headers so boost can build properly
+ CXXFLAGS+=" -DENABLE_PRECOMPILED_HEADERS=OFF"
+
+ # Flag to fix SDL exceptions occurring in some users' builds
+ CXXFLAGS+=" -I/usr/include/SDL2 -D_REENTRANT -pthread -lSDL2"
+
mkdir -p build && cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \