summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-06-21 14:42:01 -0500
committerHurricanePootis2023-06-21 14:42:01 -0500
commit4627a4b7afba8f1cce22b271f20bb2d5d642c52d (patch)
tree9075d4409468c0e5e14efa7f98dd466291991614
parent2ad29b8c3aa4cd95ab9b2e97983e6478a49852a7 (diff)
downloadaur-4627a4b7afba8f1cce22b271f20bb2d5d642c52d.tar.gz
Update submodules, new timezone stuff
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD17
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62b2fe0203a9..19609f049657 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = r24266.069d7e6be
+ pkgver = r24474.a67bdeb2c
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -55,10 +55,14 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/Microsoft/vcpkg.git
source = git+https://github.com/arun11299/cpp-jwt.git
source = git+https://github.com/bylaws/libadrenotools.git
+ source = git+https://github.com/lat9nq/tzdb_to_nx.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/google/googletest
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
source = git+https://github.com/bylaws/liblinkernsbypass.git
+ source = git+https://github.com/eggert/tz.git
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1c2c2b88f4a6..999076eca1d7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r24266.069d7e6be
+pkgver=r24474.a67bdeb2c
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -55,13 +55,16 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/Microsoft/vcpkg.git'
'git+https://github.com/arun11299/cpp-jwt.git'
'git+https://github.com/bylaws/libadrenotools.git'
+ 'git+https://github.com/lat9nq/tzdb_to_nx.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
'git+https://github.com/google/googletest'
# sirit dependencies
'git+https://github.com/KhronosGroup/SPIRV-Headers.git'
# libadrenotools' dependencies
- 'git+https://github.com/bylaws/liblinkernsbypass.git')
+ 'git+https://github.com/bylaws/liblinkernsbypass.git'
+ # tzdb_to_nx submodules
+ 'git+https://github.com/eggert/tz.git')
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -84,6 +87,8 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -94,11 +99,10 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in {inih,cubeb,dynarmic,libressl,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet};
+ for submodule in {inih,cubeb,dynarmic,libressl,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet,libadrenotools,tzdb_to_nx};
do
git config --file=.gitmodules submodule.$submodule.url "$srcdir/${submodule}"
done
- git config --file=.gitmodules submodule.externals/libadrenotools.url "$srcdir/libadrenotools"
git -c protocol.file.allow=always submodule update --init
@@ -116,6 +120,10 @@ prepare() {
cd "$srcdir/$_pkgname/externals/libadrenotools"
git config --file=.gitmodules submodule.lib/linkernsbypass.url "$srcdir/liblinkernsbypass"
git -c protocol.file.allow=always submodule update --init
+
+ cd "$srcdir/$_pkgname/externals/nx_tzdb/tzdb_to_nx/"
+ git config --file=.gitmodules submodule.externals/tz/tz.url "$srcdir/tz"
+ git -c protocol.file.allow=always submodule update --init
}
build() {
@@ -138,6 +146,7 @@ build() {
-DYUZU_USE_BUNDLED_FFMPEG=OFF \
-DYUZU_USE_BUNDLED_QT=OFF \
-DYUZU_USE_EXTERNAL_VULKAN_HEADERS=OFF \
+ -DYUZU_DOWNLOAD_TIME_ZONE_DATA=ON \
-DYUZU_TESTS=OFF \
-DENABLE_QT6=OFF \
-DUSE_DISCORD_PRESENCE=ON \