summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2022-09-28 13:26:11 -0500
committerHurricanePootis2022-09-28 13:26:11 -0500
commit4ecfbd153a3241f5e7faf187f55c363290842354 (patch)
tree015a8682e2f1d78843b39763db3ba682b108341e
parent3bde18225096daad0feb547938c5ce15052b04c5 (diff)
downloadaur-4ecfbd153a3241f5e7faf187f55c363290842354.tar.gz
Add cpp-jwt as an external dependency
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73fcde84f012..fab93d5845bf 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = r22034.3b25d1fe2
+ pkgver = r22061.40d581c0f
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -54,6 +54,7 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/libsdl-org/SDL.git
source = git+https://github.com/yhirose/cpp-httplib.git
source = git+https://github.com/Microsoft/vcpkg.git
+ source = git+https://github.com/arun11299/cpp-jwt.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/google/googletest
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
@@ -76,5 +77,6 @@ pkgbase = yuzu-mainline-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-mainline-git
diff --git a/PKGBUILD b/PKGBUILD
index ae54397c1cff..00370c5e5a4c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r22034.3b25d1fe2
+pkgver=r22061.40d581c0f
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -54,6 +54,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/libsdl-org/SDL.git'
'git+https://github.com/yhirose/cpp-httplib.git'
'git+https://github.com/Microsoft/vcpkg.git'
+ 'git+https://github.com/arun11299/cpp-jwt.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
'git+https://github.com/google/googletest'
@@ -77,6 +78,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -87,7 +89,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in {inih,cubeb,dynarmic,libressl,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg};
+ for submodule in {inih,cubeb,dynarmic,libressl,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt};
do
git config --file=.gitmodules submodule.$submodule.url "$srcdir/${submodule}"
done