summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-09-02 13:49:45 -0500
committerHurricanePootis2023-09-02 13:49:45 -0500
commit52d73a3a9d4cb3ec3008d3093bf1bf338baec361 (patch)
treef4fafbbb37519a5f0e803102dd6c10065e1ccab5
parent9d3f9b847be005c5d5cc1a22955579570e32fa25 (diff)
downloadaur-52d73a3a9d4cb3ec3008d3093bf1bf338baec361.tar.gz
Bump for boost, and add submodules for dynarmic's zydis submodule
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD11
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ac92a6a1f82..911c2f77a4c1 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = 1540.r0.g575533a
+ pkgver = 1545.r0.gf7dbd26
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
install = yuzu-mainline-git.install
@@ -63,6 +63,8 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
source = git+https://github.com/bylaws/liblinkernsbypass.git
source = git+https://github.com/eggert/tz.git
+ source = git+https://github.com/zyantific/zycore-c.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ac8f43c824ef..9c74ca9e966d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=1540.r0.g575533a
+pkgver=1545.r0.gf7dbd26
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -77,7 +77,9 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
# libadrenotools' dependencies
'git+https://github.com/bylaws/liblinkernsbypass.git'
# tzdb_to_nx submodules
- 'git+https://github.com/eggert/tz.git')
+ 'git+https://github.com/eggert/tz.git'
+ # dynarmic's zydis submodule
+ 'git+https://github.com/zyantific/zycore-c.git')
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -102,6 +104,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -138,6 +141,10 @@ prepare() {
cd "$srcdir/$_pkgname/externals/nx_tzdb/tzdb_to_nx/"
git config --file=.gitmodules submodule.externals/tz/tz.url "$srcdir/tz"
git -c protocol.file.allow=always submodule update --init
+
+ cd "$srcdir/$_pkgname/externals/dynarmic/externals/zydis"
+ git config --file=.gitmodules submodule.dependencies/zycore.url "$srcdir/zycore-c"
+ git -c protcol.file.allow=always submodule update --init
}
build() {