summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-10-31 14:39:38 -0500
committerHurricanePootis2023-10-31 14:39:38 -0500
commit59d22d1665420d4fc2c2d3377bdc7d3bb619079a (patch)
tree280d9ddf4737cedeaf71851c4ef15c81d53ebc15
parent6abb3f590aa6fc5e6ad658da0ab144e34fc6da47 (diff)
downloadaur-59d22d1665420d4fc2c2d3377bdc7d3bb619079a.tar.gz
Force yuzu to use x11 as not all graphical features are available under x11
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--yuzu-mainline-git.install8
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70ea385dfd29..4e725fc97bf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = 1597.r0.gc8c3d8c
- pkgrel = 2
+ pkgver = 1606.r0.ga0398cf
+ pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
install = yuzu-mainline-git.install
arch = i686
@@ -32,7 +32,6 @@ pkgbase = yuzu-mainline-git
depends = sdl2
depends = enet
depends = boost-libs
- optdepends = qt5-wayland: Wayland support
provides = yuzu
provides = yuzu-cmd
conflicts = yuzu-git
diff --git a/PKGBUILD b/PKGBUILD
index c7821c4c4ce3..4f60e7554544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Co-Maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=1597.r0.gc8c3d8c
-pkgrel=2
+pkgver=1606.r0.ga0398cf
+pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
url='https://github.com/yuzu-emu/yuzu-mainline'
@@ -57,7 +57,7 @@ makedepends=('boost'
'rapidjson'
'spirv-headers'
'mold')
-optdepends=("qt5-wayland: Wayland support")
+#optdepends=("qt5-wayland: Wayland support")
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/lsalzman/enet.git'
'git+https://github.com/benhoyt/inih.git'
@@ -196,4 +196,7 @@ build() {
package() {
cd "$srcdir"
DESTDIR="$pkgdir" cmake --install build
+
+ cd "$pkgdir/usr/share/applications"
+ sed -i '12s/Exec=yuzu/Exec=env QT_QPA_PLATFORM=xcb yuzu/' org.yuzu_emu.yuzu.desktop
}
diff --git a/yuzu-mainline-git.install b/yuzu-mainline-git.install
index 448ad702e20a..cd28f41878f8 100644
--- a/yuzu-mainline-git.install
+++ b/yuzu-mainline-git.install
@@ -4,6 +4,10 @@ cat << EOF
Remember to rebuild yuzu-mainline-git periodically to get the latest changes.
If you are to keep your build files, building a newer version should
take significantly shorter time.
+
+Notice: Make sure yuzu is running under x11, as not all vsync features are
+available under wayland, and can lead to degraded performance on graphically
+limited systems.
=============================================================================
EOF
}
@@ -14,6 +18,10 @@ cat << EOF
Remember to rebuild yuzu-mainline-git periodically to get the latest changes.
If you are to keep your build files, building a newer version should
take significantly shorter time.
+
+Notice: Make sure yuzu is running under x11, as not all vsync features are
+available under wayland, and can lead to degraded performance on graphically
+limited systems.
=============================================================================
EOF
}