summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-07-03 10:36:52 -0700
committerHurricanePootis2023-07-03 10:36:52 -0700
commit618ee287008319cdf15bbea2a140c46fd3789125 (patch)
treef6f04c5a310b20ed9ee325a2f3a692f5834108ed
parentd2c7fffbf07c7ea3939f3383727ad57196cd7580 (diff)
downloadaur-618ee287008319cdf15bbea2a140c46fd3789125.tar.gz
Update submodules
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD8
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8786a76af976..2b21dcabe18e 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = 1479.r0.ge6255ba
+ pkgver = 1485.r0.g95ceae4
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -56,6 +56,7 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/arun11299/cpp-jwt.git
source = git+https://github.com/bylaws/libadrenotools.git
source = git+https://github.com/lat9nq/tzdb_to_nx.git
+ source = git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/google/googletest
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
@@ -86,5 +87,6 @@ pkgbase = yuzu-mainline-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-mainline-git
diff --git a/PKGBUILD b/PKGBUILD
index 770bab58d8e5..b6c2029b690a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=1479.r0.ge6255ba
+pkgver=1485.r0.g95ceae4
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -67,6 +67,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/arun11299/cpp-jwt.git'
'git+https://github.com/bylaws/libadrenotools.git'
'git+https://github.com/lat9nq/tzdb_to_nx.git'
+ 'git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
'git+https://github.com/google/googletest'
@@ -100,6 +101,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -111,7 +113,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in {inih,cubeb,dynarmic,libressl,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet,libadrenotools,tzdb_to_nx};
+ for submodule in {inih,cubeb,dynarmic,libressl,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator};
do
git config --file=.gitmodules submodule.$submodule.url "$srcdir/${submodule}"
done
@@ -141,7 +143,7 @@ prepare() {
build() {
cd "$srcdir"
- [[ -d build ]] && rm -rf build
+ #[[ -d build ]] && rm -rf build
cmake -S $_pkgname -B build \
-GNinja \