summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2021-08-25 22:03:27 -0400
committerBrendan Szymanski2021-08-25 22:03:27 -0400
commit7e11cdf7a9465ac5b6d752dbb64c6216a9335da7 (patch)
tree5a639692042560b345ec6f79ca03fe2adfd16842
parentc29cd774d9d6f553665f607901a32e71bf543017 (diff)
downloadaur-7e11cdf7a9465ac5b6d752dbb64c6216a9335da7.tar.gz
Added compatability list support, updated dependencies to reduce build time
-rwxr-xr-x.SRCINFO12
-rwxr-xr-xPKGBUILD31
2 files changed, 26 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a279b566db6..062e70c758ed 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
pkgbase = yuzu-mainline-git
- pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r18479.7b86a68ee
+ pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
+ pkgver = r19501.f81aa7a17
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
arch = x86_64
license = GPL2
+ makedepends = boost
makedepends = catch2
makedepends = cmake
makedepends = fmt
+ makedepends = ffmpeg
makedepends = git
+ makedepends = ninja
makedepends = nlohmann-json
depends = desktop-file-utils
depends = glslang
- depends = libxkbcommon-x11
depends = libfdk-aac
+ depends = libxkbcommon-x11
+ depends = libzip
depends = lz4
+ depends = mbedtls
depends = openssl
+ depends = opus
depends = qt5-base
depends = qt5-multimedia
depends = qt5-tools
diff --git a/PKGBUILD b/PKGBUILD
index e78b28852c82..3300122dc9e4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Brendan Szymanski <bscubed@pm.me>
+# Maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r18479.7b86a68ee
+pkgver=r19501.f81aa7a17
pkgrel=1
-pkgdesc='An experimental open-source Nintendo Switch emulator/debugger'
+pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
url='https://github.com/yuzu-emu/yuzu-mainline'
license=('GPL2')
@@ -12,10 +12,13 @@ provides=('yuzu' 'yuzu-cmd')
conflicts=('yuzu-git' 'yuzu-canary-git')
depends=('desktop-file-utils'
'glslang'
- 'libxkbcommon-x11'
'libfdk-aac'
+ 'libxkbcommon-x11'
+ 'libzip'
'lz4'
+ 'mbedtls'
'openssl'
+ 'opus'
'qt5-base'
'qt5-multimedia'
'qt5-tools'
@@ -25,7 +28,14 @@ depends=('desktop-file-utils'
'shared-mime-info'
'zlib'
'zstd')
-makedepends=('catch2' 'cmake' 'fmt' 'git' 'nlohmann-json')
+makedepends=('boost'
+ 'catch2'
+ 'cmake'
+ 'fmt'
+ 'ffmpeg'
+ 'git'
+ 'ninja'
+ 'nlohmann-json')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/benhoyt/inih.git'
'git+https://github.com/kinetiknz/cubeb.git'
@@ -101,13 +111,6 @@ prepare() {
build() {
cd "$srcdir/$_pkgname"
- # Trick the compiler into thinking we're building from a continuous
- # integration tool so the build number is correctly shown in the title
- export CI=true
- export TRAVIS=true
- export TRAVIS_REPO_SLUG=yuzu-emu/yuzu-mainline
- export TRAVIS_TAG=$(git describe --tags)
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -116,9 +119,9 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DENABLE_QT_TRANSLATION=ON \
- -DYUZU_USE_BUNDLED_BOOST=ON \
-DYUZU_USE_QT_WEB_ENGINE=ON \
- -DUSE_DISCORD_PRESENCE=ON
+ -DUSE_DISCORD_PRESENCE=ON \
+ -DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON
make
}