summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-08-28 10:09:40 -0500
committerHurricanePootis2023-08-28 10:09:40 -0500
commit9d3f9b847be005c5d5cc1a22955579570e32fa25 (patch)
treeb7a2baef93c6ab3422b417a23d85b3f0992a3926
parent088bc95632358b51756e85b069adf0a7b3b410c6 (diff)
downloadaur-9d3f9b847be005c5d5cc1a22955579570e32fa25.tar.gz
Use github mirror of ffmpeg and add reminder to users
-rwxr-xr-x.SRCINFO5
-rwxr-xr-xPKGBUILD5
-rw-r--r--yuzu-mainline-git.install19
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0efe9d1c638..0ac92a6a1f82 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = 1518.r8.g85e3575
+ pkgver = 1540.r0.g575533a
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
+ install = yuzu-mainline-git.install
arch = i686
arch = x86_64
license = GPL2
@@ -49,7 +50,7 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/yuzu-emu/mbedtls.git
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/xiph/opus.git
- source = git+https://git.ffmpeg.org/ffmpeg.git
+ source = ffmpeg::git+https://github.com/FFmpeg/FFmpeg.git
source = git+https://github.com/libsdl-org/SDL.git
source = git+https://github.com/yhirose/cpp-httplib.git
source = git+https://github.com/Microsoft/vcpkg.git
diff --git a/PKGBUILD b/PKGBUILD
index d8ccf018ca36..ac8f43c824ef 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=1518.r8.g85e3575
+pkgver=1540.r0.g575533a
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -10,6 +10,7 @@ url='https://github.com/yuzu-emu/yuzu-mainline'
license=('GPL2')
provides=('yuzu' 'yuzu-cmd')
conflicts=('yuzu-git' 'yuzu-canary-git' 'yuzu')
+install=$pkgname.install
_debug=false # set to true to debug yuzu. Whenever debugging with gdb, remember to enter `handle SIGSEGV nostop` before `run`, as yuzu uses SIGSEGV for memory access!!!!!!!!`
if [ "$_debug" = false ]
then
@@ -60,7 +61,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/yuzu-emu/mbedtls.git'
'git+https://github.com/herumi/xbyak.git'
'git+https://github.com/xiph/opus.git'
- 'git+https://git.ffmpeg.org/ffmpeg.git'
+ 'ffmpeg::git+https://github.com/FFmpeg/FFmpeg.git'
'git+https://github.com/libsdl-org/SDL.git'
'git+https://github.com/yhirose/cpp-httplib.git'
'git+https://github.com/Microsoft/vcpkg.git'
diff --git a/yuzu-mainline-git.install b/yuzu-mainline-git.install
new file mode 100644
index 000000000000..448ad702e20a
--- /dev/null
+++ b/yuzu-mainline-git.install
@@ -0,0 +1,19 @@
+post_install() {
+cat << EOF
+=============================================================================
+Remember to rebuild yuzu-mainline-git periodically to get the latest changes.
+If you are to keep your build files, building a newer version should
+take significantly shorter time.
+=============================================================================
+EOF
+}
+
+post_upgrade() {
+cat << EOF
+=============================================================================
+Remember to rebuild yuzu-mainline-git periodically to get the latest changes.
+If you are to keep your build files, building a newer version should
+take significantly shorter time.
+=============================================================================
+EOF
+}