summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-11-20 10:41:50 -0600
committerHurricanePootis2023-11-20 10:41:50 -0600
commita471fa850db987c97e59fe8f13cd5e35101d3b59 (patch)
tree2cc77caf150f31a4b500bfd56333813173c5f91d
parent7f9d6f228dbfafda389349b893525d9d377d5363 (diff)
downloadaur-a471fa850db987c97e59fe8f13cd5e35101d3b59.tar.gz
Add clang dep for new submodule, simpleini
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89df3d68c362..24736e78973f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = 1614.r0.gecdd386
+ pkgver = 1627.r0.g52ce8ee
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
install = yuzu-mainline-git.install
@@ -11,6 +11,7 @@ pkgbase = yuzu-mainline-git
makedepends = glslang
makedepends = llvm
makedepends = gcc
+ makedepends = clang
makedepends = catch2
makedepends = cmake
makedepends = ffmpeg
@@ -59,6 +60,7 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/lat9nq/tzdb_to_nx.git
source = git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
source = git+https://github.com/yuzu-emu/breakpad.git
+ source = git+https://github.com/brofield/simpleini.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/google/googletest
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
@@ -92,5 +94,6 @@ pkgbase = yuzu-mainline-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-mainline-git
diff --git a/PKGBUILD b/PKGBUILD
index a311226c0035..6ece585b59af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=1614.r0.gecdd386
+pkgver=1627.r0.g52ce8ee
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -44,6 +44,7 @@ makedepends=('boost'
'glslang'
'llvm'
'gcc'
+ 'clang'
'catch2'
'cmake'
'ffmpeg'
@@ -78,6 +79,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/lat9nq/tzdb_to_nx.git'
'git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git'
'git+https://github.com/yuzu-emu/breakpad.git'
+ 'git+https://github.com/brofield/simpleini.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
'git+https://github.com/google/googletest'
@@ -115,6 +117,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -127,7 +130,7 @@ prepare() {
cd "$srcdir/$_pkgname"
git submodule init
- for submodule in {inih,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator,breakpad};
+ for submodule in {inih,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator,breakpad,simpleini};
do
git config submodule.$submodule.url "$srcdir/${submodule}"
done