summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2021-07-24 22:56:53 -0400
committerBrendan Szymanski2021-07-24 22:56:53 -0400
commitc29cd774d9d6f553665f607901a32e71bf543017 (patch)
treed029d94320fedf0b12d1c859fa1e746f4a08a1c9
parent8fadddebfa13a0478c0dd63f03d333f5d7385193 (diff)
downloadaur-c29cd774d9d6f553665f607901a32e71bf543017.tar.gz
Added httplib to submodule dependencies. Updated Discord dependency to new upstream URL
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e30dca39c6f6..5a279b566db6 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r17731.ea377477f
+ pkgver = r18479.7b86a68ee
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -37,7 +37,7 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/citra-emu/ext-soundtouch.git
source = libressl::git+https://github.com/citra-emu/ext-libressl-portable.git
source = git+https://github.com/libusb/libusb.git
- source = git+https://github.com/discordapp/discord-rpc.git
+ source = git+https://github.com/discord/discord-rpc.git
source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = git+https://github.com/ReinUsesLisp/sirit
source = git+https://github.com/yuzu-emu/mbedtls
@@ -46,6 +46,7 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/xiph/opus.git
source = git+https://git.ffmpeg.org/ffmpeg.git
source = git+https://github.com/libsdl-org/SDL.git
+ source = git+https://github.com/yhirose/cpp-httplib.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
md5sums = SKIP
@@ -66,6 +67,6 @@ pkgbase = yuzu-mainline-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-mainline-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3b7ba105670d..e78b28852c82 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r17731.ea377477f
+pkgver=r18479.7b86a68ee
pkgrel=1
pkgdesc='An experimental open-source Nintendo Switch emulator/debugger'
arch=('i686' 'x86_64')
@@ -33,7 +33,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/citra-emu/ext-soundtouch.git'
'libressl::git+https://github.com/citra-emu/ext-libressl-portable.git'
'git+https://github.com/libusb/libusb.git'
- 'git+https://github.com/discordapp/discord-rpc.git'
+ 'git+https://github.com/discord/discord-rpc.git'
'git+https://github.com/KhronosGroup/Vulkan-Headers.git'
'git+https://github.com/ReinUsesLisp/sirit'
'git+https://github.com/yuzu-emu/mbedtls'
@@ -42,6 +42,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/xiph/opus.git'
'git+https://git.ffmpeg.org/ffmpeg.git'
'git+https://github.com/libsdl-org/SDL.git'
+ 'git+https://github.com/yhirose/cpp-httplib.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
# sirit dependencies
@@ -63,6 +64,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -73,7 +75,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,libzip/libzip,xbyak,opus/opus,ffmpeg,SDL}; do
+ for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,libzip/libzip,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
git submodule update