summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-06-28 00:11:50 -0500
committerHurricanePootis2023-06-28 00:11:50 -0500
commitd2c7fffbf07c7ea3939f3383727ad57196cd7580 (patch)
treebb0f56901641ed2383455b25b15a3cbd833c5aaa
parentd90230ad5d5a8e33f7fb6271a0913372f53334fa (diff)
downloadaur-d2c7fffbf07c7ea3939f3383727ad57196cd7580.tar.gz
Introduce a new yuzu debugging system
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD26
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62075697ad18..8786a76af976 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = 1478.r0.g3a991f3
+ pkgver = 1479.r0.ge6255ba
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 0089b42fbb64..770bab58d8e5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=1478.r0.g3a991f3
+pkgver=1479.r0.ge6255ba
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -10,8 +10,20 @@ url='https://github.com/yuzu-emu/yuzu-mainline'
license=('GPL2')
provides=('yuzu' 'yuzu-cmd')
conflicts=('yuzu-git' 'yuzu-canary-git' 'yuzu')
-# Set "!strip" to keep the debugging symbols within the package for debugging
-options=("lto" "strip") #Set LTO (Flatpak builds with Full GCC LTO)
+_debug=false # set to true to debug yuzu. Whenever debugging with gdb, remember to enter `handle SIGSEGV nostop` before `run`, as yuzu uses SIGSEGV for memory access!!!!!!!!`
+if [ "$_debug" = false ]
+then
+ options=("lto" "strip")
+ _cmake_build_type=Release
+ _yuzu_lto=ON
+else
+ options=("!lto" "!strip" "debug")
+ _cmake_build_type=Debug
+ _yuzu_lto=OFF
+fi
+
+
+
depends=('fmt'
'cubeb'
'mbedtls'
@@ -136,12 +148,12 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_C_COMPILER=gcc \
-DCMAKE_CXX_COMPILER=g++ \
- -DCMAKE_C_FLAGS="$CFLAGS -flto=auto" \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS -flto=auto" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_BUILD_TYPE=$_cmake_build_type \
-DYUZU_USE_QT_WEB_ENGINE=ON \
-DYUZU_USE_QT_MULTIMEDIA=ON \
- -DYUZU_ENABLE_LTO=ON \
+ -DYUZU_ENABLE_LTO=$_yuzu_lto \
-DYUZU_USE_EXTERNAL_SDL2=OFF \
-DYUZU_USE_BUNDLED_FFMPEG=OFF \
-DYUZU_USE_BUNDLED_QT=OFF \