summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-10-17 22:08:13 -0500
committerHurricanePootis2023-10-17 22:08:13 -0500
commitedfe6bacf6a61e012230ecbd1d819406a63b11ed (patch)
tree44327a9692def0f723206df18c5ee2f22039c9d9
parent52d73a3a9d4cb3ec3008d3093bf1bf338baec361 (diff)
downloadaur-edfe6bacf6a61e012230ecbd1d819406a63b11ed.tar.gz
Add breakpad submodule, speed up compile times, and use system spirv headers
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 911c2f77a4c1..e8da90fff0ba 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = 1545.r0.gf7dbd26
+ pkgver = 1591.r0.g378d884
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
install = yuzu-mainline-git.install
@@ -58,6 +58,7 @@ pkgbase = yuzu-mainline-git
source = git+https://github.com/bylaws/libadrenotools.git
source = git+https://github.com/lat9nq/tzdb_to_nx.git
source = git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
+ source = git+https://github.com/yuzu-emu/breakpad.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/google/googletest
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
@@ -90,5 +91,6 @@ pkgbase = yuzu-mainline-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-mainline-git
diff --git a/PKGBUILD b/PKGBUILD
index 9c74ca9e966d..248dec35381e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=1545.r0.gf7dbd26
+pkgver=1591.r0.g378d884
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -17,6 +17,8 @@ then
options=("lto" "strip")
_cmake_build_type=Release
_yuzu_lto=ON
+ CFLAGS+=" -fno-fat-lto-objects"
+ CXXFLAGS+=" -fno-fat-lto-objects"
else
options=("!lto" "!strip" "debug")
_cmake_build_type=Debug
@@ -69,6 +71,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/bylaws/libadrenotools.git'
'git+https://github.com/lat9nq/tzdb_to_nx.git'
'git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git'
+ 'git+https://github.com/yuzu-emu/breakpad.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
'git+https://github.com/google/googletest'
@@ -105,6 +108,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -116,7 +120,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in {inih,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator};
+ for submodule in {inih,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator,breakpad};
do
git config --file=.gitmodules submodule.$submodule.url "$srcdir/${submodule}"
done
@@ -159,14 +163,15 @@ build() {
-DCMAKE_CXX_COMPILER=g++ \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DYUZU_ENABLE_LTO=$_yuzu_lto \
-DCMAKE_BUILD_TYPE=$_cmake_build_type \
-DYUZU_USE_QT_WEB_ENGINE=ON \
-DYUZU_USE_QT_MULTIMEDIA=ON \
- -DYUZU_ENABLE_LTO=$_yuzu_lto \
-DYUZU_USE_EXTERNAL_SDL2=OFF \
-DYUZU_USE_BUNDLED_FFMPEG=OFF \
-DYUZU_USE_BUNDLED_QT=OFF \
-DYUZU_USE_EXTERNAL_VULKAN_HEADERS=OFF \
+ -DSIRIT_USE_SYSTEM_SPIRV_HEADERS=ON \
-DYUZU_DOWNLOAD_TIME_ZONE_DATA=ON \
-DYUZU_TESTS=OFF \
-DENABLE_QT6=OFF \