summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-03-22 12:06:09 -0500
committerHurricanePootis2023-03-22 12:06:09 -0500
commitf1b15c5398c890facc4adac16f5f2a3f29a6d38d (patch)
treed92c649bea4e9816171be70752ed156a064e5501
parentd9cc16f63e4ca6a12a189cf08d7f6fa40a119ebe (diff)
downloadaur-f1b15c5398c890facc4adac16f5f2a3f29a6d38d.tar.gz
Move back to QT5, QT6 has problems with scaling method and anti-aliasing
-rwxr-xr-x.SRCINFO10
-rwxr-xr-xPKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 060e9ad00bca..146e62c2e72f 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = r23396.c1730f5d8
+ pkgver = r23453.76289c2e9
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -15,18 +15,18 @@ pkgbase = yuzu-mainline-git
makedepends = git
makedepends = ninja
makedepends = nlohmann-json
- makedepends = qt6-tools
+ makedepends = qt5-tools
makedepends = robin-map
depends = fmt
depends = cubeb
depends = mbedtls
depends = libinih
- depends = qt6-multimedia
- depends = qt6-webengine
+ depends = qt5-multimedia
+ depends = qt5-webengine
depends = sdl2
depends = enet
depends = boost-libs
- optdepends = qt6-wayland: Wayland support
+ optdepends = qt5-wayland: Wayland support
provides = yuzu
provides = yuzu-cmd
conflicts = yuzu-git
diff --git a/PKGBUILD b/PKGBUILD
index 5b08d187ea37..a110451aa2e3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r23396.c1730f5d8
+pkgver=r23453.76289c2e9
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -16,8 +16,8 @@ depends=('fmt'
'cubeb'
'mbedtls'
'libinih'
- 'qt6-multimedia'
- 'qt6-webengine'
+ 'qt5-multimedia'
+ 'qt5-webengine'
'sdl2'
'enet'
'boost-libs')
@@ -30,9 +30,9 @@ makedepends=('boost'
'git'
'ninja'
'nlohmann-json'
- 'qt6-tools'
+ 'qt5-tools'
'robin-map')
-optdepends=("qt6-wayland: Wayland support")
+optdepends=("qt5-wayland: Wayland support")
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
'git+https://github.com/lsalzman/enet.git'
'git+https://github.com/benhoyt/inih.git'
@@ -121,7 +121,7 @@ build() {
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DYUZU_USE_QT_WEB_ENGINE=ON \
-DYUZU_USE_QT_MULTIMEDIA=ON \
- -DENABLE_QT6=ON \
+ -DENABLE_QT6=OFF \
-DYUZU_USE_EXTERNAL_SDL2=OFF \
-DUSE_DISCORD_PRESENCE=ON \
-DENABLE_QT_TRANSLATION=ON \