summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMonson Shao2020-07-03 23:18:48 +0800
committerMonson Shao2020-07-03 23:18:48 +0800
commit7cbbb353912b65b77aa82ce67e124096a7039d5c (patch)
tree33cd5b0f3e7fe5b87f0d11a3036cfc0e616df52e
parent1d92fd2c3aa1d1f77dea3f4aff0b83aceae284b8 (diff)
downloadaur-7cbbb353912b65b77aa82ce67e124096a7039d5c.tar.gz
update to 1.8.7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e596609df80..1573b525d582 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = z.lua
pkgdesc = A new cd command that helps you navigate faster by learning your habits
- pkgver = 1.8.4
+ pkgver = 1.8.7
pkgrel = 1
url = https://github.com/skywind3000/z.lua
arch = any
license = MIT
depends = lua
- provides = z.lua
- conflicts = z.lua-git
- replaces = z.lua-git
- source = https://github.com/skywind3000/z.lua/archive/1.8.4.tar.gz
- sha256sums = ae26580b5e0a3b3d82a932804e0d2cd9ead44cbb49edb3360d3c00d4ae12f06b
+ source = https://github.com/skywind3000/z.lua/archive/1.8.7.tar.gz
+ sha256sums = 8c67ae52c9c3926b16f0c64a046726c3d872de92add10b1ba1b0c4a659271be9
pkgname = z.lua
diff --git a/PKGBUILD b/PKGBUILD
index 3039fa0219c2..04e1df00ca1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,15 @@
# Maintainer: Javier Tia <javier dot tia at gmail dot com>
pkgname=z.lua
-pkgver=1.8.4
+pkgver=1.8.7
pkgrel=1
pkgdesc='A new cd command that helps you navigate faster by learning your habits'
arch=('any')
url='https://github.com/skywind3000/z.lua'
license=('MIT')
depends=('lua')
-provides=("${pkgname}")
-conflicts=("${pkgname}-git")
-replaces=("${pkgname}-git")
source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('ae26580b5e0a3b3d82a932804e0d2cd9ead44cbb49edb3360d3c00d4ae12f06b')
+sha256sums=('8c67ae52c9c3926b16f0c64a046726c3d872de92add10b1ba1b0c4a659271be9')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -21,5 +18,3 @@ package() {
init.fish README.md test_path.lua z.cmd z.lua z.lua.plugin.zsh
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname%-*}/" LICENSE
}
-
-# vim:set ts=2 sw=2 et: