summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2021-02-09 13:43:23 +0100
committerAntoine Viallon2021-02-09 13:43:23 +0100
commit8589dbf852af7f749ee7a27547efb401b209eb5b (patch)
treed64c595c635826de227f0980286d2d7e54576700
parentc3e719999ccc2bb3ce6f3bca61c181965166fd83 (diff)
downloadaur-z88dk-git.tar.gz
Change pkgver function, add missing submodules and disable automatic ccache
-rw-r--r--.SRCINFO14
-rw-r--r--0001-disable-forced-ccache.patch11
-rw-r--r--PKGBUILD47
-rw-r--r--z88dk.sh4
4 files changed, 58 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 933a5b24c57f..d8ca1b4cbb9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = z88dk-git
pkgdesc = The development kit for over fifty z80 machines - c compiler, assembler, linker, libraries.
- pkgver = de7d7119a
+ pkgver = v2.1.r19.g7c6df7ac3
pkgrel = 1
url = https://www.z88dk.org
arch = x86_64
@@ -10,11 +10,19 @@ pkgbase = z88dk-git
conflicts = z88dk
source = z88dk-git::git+https://github.com/z88dk/z88dk.git
source = z88dk.sh
- source = unixem::git+https://github.com/z88dk/UNIXem.git
+ source = 0001-disable-forced-ccache.patch
+ source = UNIXem::git+https://github.com/z88dk/UNIXem.git
+ source = Unity::git+https://github.com/ThrowTheSwitch/Unity.git
+ source = cpm::git+https://github.com/z88dk/cpm.git
source = optparse::git+https://github.com/skeeto/optparse.git
+ source = regex::git+https://github.com/geoffmcl/regex.git
source = uthash::git+https://github.com/z88dk/uthash.git
sha256sums = SKIP
- sha256sums = d9e302908dd3355440901254c48ffa43af273ec710ce442db77406c378f1942d
+ sha256sums = 0474d26668224231cffeaef33776020ee65fe83c825833c9907e4766d9104869
+ sha256sums = f785924a5e0e10f327408ad1362f2923a1684f58e66af715c21f8469a5bbaa1a
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/0001-disable-forced-ccache.patch b/0001-disable-forced-ccache.patch
new file mode 100644
index 000000000000..3a587dfe0e2c
--- /dev/null
+++ b/0001-disable-forced-ccache.patch
@@ -0,0 +1,11 @@
+--- Makefile 2021-02-09 12:30:57.700282539 +0100
++++ Makefile 2021-02-09 12:31:06.658439895 +0100
+@@ -30,4 +30,4 @@
+-ifneq (, $(shell which ccache))
+- OCC := $(CC)
+- CC := ccache $(CC)
+-endif
++#ifneq (, $(shell which ccache))
++# OCC := $(CC)
++# CC := ccache $(CC)
++#endif
diff --git a/PKGBUILD b/PKGBUILD
index 181aed25673d..55b275a8cdf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Jan Baudisch <dev@baudisch.xyz>
+# Maintainer: Antoien Viallon <antoine+aur@lesviallon.fr>
+# Contributor: Jan Baudisch <dev@baudisch.xyz>
pkgname=z88dk-git
-pkgver=de7d7119a
+pkgver=v2.1.r19.g7c6df7ac3
pkgrel=1
pkgdesc="The development kit for over fifty z80 machines - c compiler, assembler, linker, libraries."
arch=("x86_64")
@@ -11,32 +12,50 @@ provides=("z88dk")
conflicts=("z88dk")
source=("$pkgname::git+https://github.com/z88dk/z88dk.git"
"z88dk.sh"
- "unixem::git+https://github.com/z88dk/UNIXem.git"
+ "0001-disable-forced-ccache.patch"
+ "UNIXem::git+https://github.com/z88dk/UNIXem.git"
+ "Unity::git+https://github.com/ThrowTheSwitch/Unity.git"
+ "cpm::git+https://github.com/z88dk/cpm.git"
"optparse::git+https://github.com/skeeto/optparse.git"
- "uthash::git+https://github.com/z88dk/uthash.git")
-sha256sums=("SKIP"
- "d9e302908dd3355440901254c48ffa43af273ec710ce442db77406c378f1942d"
- "SKIP"
- "SKIP"
- "SKIP")
+ "regex::git+https://github.com/geoffmcl/regex.git"
+ "uthash::git+https://github.com/z88dk/uthash.git"
+ )
+
+sha256sums=('SKIP'
+ '0474d26668224231cffeaef33776020ee65fe83c825833c9907e4766d9104869'
+ 'f785924a5e0e10f327408ad1362f2923a1684f58e66af715c21f8469a5bbaa1a'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "$pkgname"
- git rev-parse --short HEAD
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$pkgname"
git submodule init
- git config submodule.UNIXem.url $srcdir/unixem
- git config submodule.optparse.url $srcdir/optparse
- git config submodule.uthash.url $srcdir/uthash
- git submodule update
+ _submodules=(UNIXem Unity cpm optparse regex uthash)
+ for submodule in ${_submodules[@]}; do
+ git config submodule.${submodule}.url "$srcdir/${submodule}"
+ done
+ git submodule update --recursive
+
+ for patch in $(cd "$srcdir" && ls *.patch); do
+ echo "Applying patch '$patch'..."
+ patch -d "$srcdir/$pkgname" -i "$srcdir/"${patch}
+ done
}
build() {
cd "$pkgname"
chmod +x build.sh
+ export CFLAGS="$CFLAGS -Wno-unused-value -Wno-unused-result"
./build.sh
}
diff --git a/z88dk.sh b/z88dk.sh
index f5671d8c6792..1882c4f8c927 100644
--- a/z88dk.sh
+++ b/z88dk.sh
@@ -1 +1,3 @@
-export ZCCCFG=/usr/share/z88dk/lib/config
+export ZCCCFG=/usr/share/z88dk/lib/config/
+export Z80_OZFILES=/usr/share/z88dk/lib/
+