summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2024-05-14 15:42:07 +0200
committerChristopher Arndt2024-05-14 15:42:07 +0200
commitb4b41bf53f2760c4ce647d30b586729fcf0eb329 (patch)
treeccab6089f63af4e07db57718c05e4690f5bfa79a
parent7544a44581d6c4e3c9a034d64a64cff7b16e4567 (diff)
downloadaur-zam-plugins-git.tar.gz
Build with SKIP_NATIVE_AUDIO_FALLBACK=true to prevent accidental dependency on libpulse/alsa
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce05dca4c156..0310dbfe11b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zam-plugins-git
pkgdesc = Collection of multi-format audio plugins for high-quality processing (git version)
pkgver = 4.3.r0.g9e824af
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/zamaudio/zam-plugins
arch = x86_64
groups = clap-plugins
@@ -11,8 +11,8 @@ pkgbase = zam-plugins-git
groups = vst-plugins
groups = vst3-plugins
license = GPL2
- makedepends = alsa-lib
makedepends = dbus
+ makedepends = fftw
makedepends = gendesk
makedepends = git
makedepends = ladspa
@@ -68,8 +68,8 @@ pkgname = zam-plugins-git
depends = libxcursor
depends = libxext
depends = libxrandr
- depends = libasound.so
depends = libdbus-1.so
+ depends = libfftw3f.so
depends = libGL.so
depends = libsamplerate.so
depends = libzita-convolver.so
diff --git a/PKGBUILD b/PKGBUILD
index 2e5d689f32e7..84a46684d58f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
_pkgname=zam-plugins
pkgname=$_pkgname-git
pkgver=4.3.r0.g9e824af
-pkgrel=2
+pkgrel=3
pkgdesc='Collection of multi-format audio plugins for high-quality processing (git version)'
arch=(x86_64)
url='https://github.com/zamaudio/zam-plugins'
license=(GPL2)
groups=(clap-plugins ladspa-plugins lv2-plugins pro-audio vst-plugins vst3-plugins)
depends=(gcc-libs glibc libglvnd libx11 libxcursor libxext libxrandr)
-makedepends=(alsa-lib dbus gendesk git ladspa libsamplerate jack lv2 zita-convolver)
+makedepends=(dbus fftw gendesk git ladspa libsamplerate jack lv2 zita-convolver)
optdepends=(
'clap-host: to load the CLAP format plugins'
'jack: to run the standalone applications'
@@ -72,8 +72,6 @@ prepare() {
git submodule set-url dgl/src/pugl-upstream "$srcdir"/pugl
git -c protocol.file.allow=always submodule update
- cd ..
-
declare -A exec_names=(
[zamautosat]=ZaAutoSat
[zamaximx2]=ZaMaximX2
@@ -134,6 +132,7 @@ prepare() {
[zamulticompx2]="Stereo Multiband Compressor"
[zamverb]="Reverb"
)
+ cd ..
for name in "${_names[@]}"; do
gendesk -f -n \
--pkgname "com.zamaudio.$name" \
@@ -147,11 +146,12 @@ prepare() {
build() {
cd $_pkgname
export HAVE_ZITA_CONVOLVER=true
- make
+ make SKIP_NATIVE_AUDIO_FALLBACK=true
}
package() {
- depends+=(libasound.so libdbus-1.so libGL.so libsamplerate.so libzita-convolver.so)
+ depends+=(libdbus-1.so libfftw3f.so libGL.so libsamplerate.so
+ libzita-convolver.so)
cd $_pkgname
make DESTDIR="$pkgdir" PREFIX=/usr install
# XDG desktop integration